This patch adds a header file that is present in the ripperx git and needed for inclusion, but missing in the distribution tarball. diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h --- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100 +++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200 @@ -0,0 +1,39 @@ +#ifndef gtk_cpp_workaround_h +#define gtk_cpp_workaround_h +#ifdef __cplusplus +//proto is wrong, override here for C++ +namespace +{ + +inline void gtk_table_attach (GtkTable *table, + GtkWidget *child, + guint left_attach, + guint right_attach, + guint top_attach, + guint bottom_attach, + //GtkAttachOptions xoptions, + //GtkAttachOptions yoptions, + guint xoptions, guint yoptions, + guint xpadding, + guint ypadding + ) +{ + gtk_table_attach(table, + child, + left_attach, + right_attach, + top_attach, + bottom_attach, + (GtkAttachOptions)xoptions, + (GtkAttachOptions)yoptions, + xpadding, + ypadding + ); + + }; + + +} + +#endif +#endif g/gnu/packages/spice.scm'>logtreecommitdiff
path: root/gnu/packages/spice.scm
AgeCommit message (Expand)Author
2019-03-31gnu: Fix descriptions to not use quotes....Efraim Flashner
2019-02-25gnu: Remove spice-protocol@0.12.14....Rutger Helling
2019-02-09gnu: Add spice-protocol@0.12.14....Rutger Helling
2019-02-09Merge branch 'staging'Ludovic Courtès
2019-02-08gnu: spice-protocol: Update to 0.12.15....Tobias Geerinckx-Rice
2018-12-12gnu: glib-networking: Update to 2.58.0....Marius Bakke
2018-11-18gnu: spice: Run tests sequentially....Ludovic Courtès
2018-11-13gnu: spice-vdagent: Fix typo in desktop file....Taegil Bae
2018-09-11gnu: spice: Update to 0.14.1 [fixes CVE-2018-10873]....Marius Bakke
2018-09-11gnu: usbredir: Update to 0.8.0....Marius Bakke