This patch adds a header file that is present in the ripperx git and needed for inclusion, but missing in the distribution tarball. diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h --- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100 +++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200 @@ -0,0 +1,39 @@ +#ifndef gtk_cpp_workaround_h +#define gtk_cpp_workaround_h +#ifdef __cplusplus +//proto is wrong, override here for C++ +namespace +{ + +inline void gtk_table_attach (GtkTable *table, + GtkWidget *child, + guint left_attach, + guint right_attach, + guint top_attach, + guint bottom_attach, + //GtkAttachOptions xoptions, + //GtkAttachOptions yoptions, + guint xoptions, guint yoptions, + guint xpadding, + guint ypadding + ) +{ + gtk_table_attach(table, + child, + left_attach, + right_attach, + top_attach, + bottom_attach, + (GtkAttachOptions)xoptions, + (GtkAttachOptions)yoptions, + xpadding, + ypadding + ); + + }; + + +} + +#endif +#endif gnu/packages/ipfs.scm'>logtreecommitdiff
path: root/gnu/packages/ipfs.scm
AgeCommit message (Expand)Author
2019-04-25gnu, guix: Yearly ritual purging of the filesystems....Tobias Geerinckx-Rice
2019-03-16gnu: go-ipfs: Update to 0.4.19....Tobias Geerinckx-Rice
2019-03-14gnu: Remove the various Go union meta-packages....Leo Famulari
2019-02-04gnu: gx, go-github-com-whyrusleeping-gx-util: Update to 0.14.1....Tobias Geerinckx-Rice
2018-12-13gnu: go-ipfs: Work around tar bomb....Ludovic Courtès
2018-12-09gnu: Add go-ipfs....Pierre Neidhardt
2018-10-24gnu: Add gx-go....Pierre Neidhardt
2018-10-24gnu: Add go-github-com-whyrusleeping-gx-util....Pierre Neidhardt
2018-10-24gnu: Add gx....Pierre Neidhardt
2018-10-24gnu: Add go-github-com-ipfs-go-ipfs-api....Pierre Neidhardt
2018-10-24gnu: Add go-github-com-ipfs-go-ipfs-cmdkit-files....Pierre Neidhardt