This patch adds a header file that is present in the ripperx git and needed
for inclusion, but missing in the distribution tarball.
diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h
--- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100
+++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200
@@ -0,0 +1,39 @@
+#ifndef gtk_cpp_workaround_h
+#define gtk_cpp_workaround_h
+#ifdef __cplusplus
+//proto is wrong, override here for C++
+namespace
+{
+
+inline void gtk_table_attach (GtkTable *table,
+ GtkWidget *child,
+ guint left_attach,
+ guint right_attach,
+ guint top_attach,
+ guint bottom_attach,
+ //GtkAttachOptions xoptions,
+ //GtkAttachOptions yoptions,
+ guint xoptions, guint yoptions,
+ guint xpadding,
+ guint ypadding
+ )
+{
+ gtk_table_attach(table,
+ child,
+ left_attach,
+ right_attach,
+ top_attach,
+ bottom_attach,
+ (GtkAttachOptions)xoptions,
+ (GtkAttachOptions)yoptions,
+ xpadding,
+ ypadding
+ );
+
+ };
+
+
+}
+
+#endif
+#endif
ef='/guix/log/gnu/packages/syndication.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2020-04-05 | gnu: Add tuir....* gnu/packages/syndication.scm (tuir): New variable.
| Efraim Flashner |
2020-03-29 | gnu: Remove more packages deprecated for over almost a year....* gnu/packages/games.scm (armagetron-advanced)
(cataclysm-dark-days-ahead, gnubackgammon, l-abbaye-des-morts)
(the-battle-for-wesnoth, the-battle-for-wesnoth-server)
(project-starfighter, kiki-the-nano-bot, fish-fillets-ng)
(dungeon-crawl-stone-soup): Let's forget this ever happened.
* gnu/packages/emacs-xyz.scm (geiser, paredit, git-modes/old-name)
(magit, magit-svn, haskell-mode, emacs-emms-player-mpv, bbdb)
(ert-runner, groovy-emacs-modes): Remove variable.
* gnu/packages/engineering.scm (emacs-emms-player-simple-mpv)
(emacs-evil-ediff, emacs-evil-mu4e, emacs-wgrep-helm, ao): Likewise.
* gnu/packages/finance.scm (monero-core): Likewise.
* gnu/packages/gnome.scm (dungeon-crawl-stone-soup-tiles)
(tales-of-maj-eyal, battle-tanks, the-legend-of-edgar)
(gnome-tweak-tool): Likewise.
* gnu/packages/gnuzilla.scm (conkeror): Likewise.
* gnu/packages/guile-xyz.scm (mcron2): Likewise.
* gnu/packages/image.scm (pngcrunch): Likewise.
* gnu/packages/linux.scm (eudev-with-hwdb): Likewise.
* gnu/packages/maths.scm (qtoctave): Likewise.
* gnu/packages/package-management.scm (guile2.0-guix): Likewise.
* gnu/packages/php.scm (php-with-bcmath): Likewise.
* gnu/packages/python-xyz.scm (python-kivy-next, python2-kivy-next):
Likewise.
* gnu/packages/video.scm (livestreamer): Likewise.
* gnu/packages/virtualization.scm (lookingglass): Likewise.
* gnu/packages/vulkan.scm (vulkan-icd-loader): Likewise.
* gnu/packages/syndication.scm (newsbeuter): Likewise.
(newsboat)[description]: Remove historical footnote.
| Tobias Geerinckx-Rice |