From 5193b137b5a9034ce79946edd40760df2f63a82a Mon Sep 17 00:00:00 2001 From: Jean Delvare Date: Tue, 25 Apr 2017 15:17:53 +0200 Subject: test: Escape curly braces in regex Curly braces in perl regex are supposed to be escaped, recent versions of perl complain when they aren't: Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE (\w+)}/ at ./run line 114. Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE \?}/ at ./run line 290. Signed-off-by: Jean Delvare --- test/run | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/test/run b/test/run index 942014e..03afc7a 100755 --- a/test/run +++ b/test/run @@ -112,7 +112,7 @@ sub flush_output() sub substitute_vars($) { my ($line) = @_; - $line =~ s[%{(\w+)}][defined $ENV{$1} ? $ENV{$1} : ""]eg; + $line =~ s[%\{(\w+)\}][defined $ENV{$1} ? $ENV{$1} : ""]eg; return $line; } @@ -288,7 +288,7 @@ while (defined(my $line = )) { # Parse the next command if ($line =~ s/^\s*\$ ?//) { # Substitute %{?} with the last command's status - $line =~ s[%{\?}][$last_status]eg; + $line =~ s[%\{\?\}][$last_status]eg; chomp($prog = substitute_vars($line)); $prog_line = $lineno; -- cgit v1.0-41-gc330 de0db4e9bbb799ad67'>commitdiff
AgeCommit message (Expand)Author
2021-06-01maint: Require Guile 3.0....Ludovic Courtès
2021-05-03nls: Do not update po files on first make invocation....Julien Lepiller
2021-04-25import: Remove Nix importer....Ludovic Courtès
2021-04-23build: Add a check for Guile-Lib....Maxim Cournoyer
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-27maint: Remove unused '--with-nix-prefix' configure option....Ludovic Courtès
2020-12-19maint: Require Guile >= 2.2.6....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-11-29Make "guile-avahi" dependency optional....Mathieu Othacehe
2020-11-29Add Avahi support....Mathieu Othacehe
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-10-05build: Use a 'guile' executable that doesn't warn about locales....Ludovic Courtès
2020-08-29build: Remove references to the 'nix-hash' program....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe