Fix check for dmenu (open file mode, dependency on which). See . --- quickswitch-i3-2.2/quickswitch.py 2016-09-18 19:59:10.257765542 +0200 +++ quickswitch-i3-2.2/quickswitch.py 2016-09-21 10:43:01.277577819 +0200 @@ -24,9 +24,10 @@ import argparse import subprocess -import os import re +from distutils.spawn import find_executable + try: import i3 except ImportError: @@ -37,11 +38,8 @@ def check_dmenu(): '''Check if dmenu is available.''' - devnull = open(os.devnull) - retcode = subprocess.call(["which", "dmenu"], - stdout=devnull, - stderr=devnull) - return True if retcode == 0 else False + executable = find_executable("dmenu") + return executable != None def dmenu(options, dmenu): mit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/pam.scm
AgeCommit message (Expand)Author
2017-09-22services: Move 'session-environment-service-type' to pam.scm....Ludovic Courtès
2017-05-08system: Allow root to run "su" without password....Ricardo Wurmus
2016-11-06gnu: Remove comment which is factually incorrect....John Darrington
2016-07-19services: Add pam-limits-service....Ricardo Wurmus
2016-02-06system: pam: 'pam-root-service-type' can be extended with transformations....Ludovic Courtès
2016-02-06system: pam: Export accessors....Ludovic Courtès
2015-12-05system: pam: Honor /etc/environment....宋文武
2015-11-03system: Rename (gnu system linux) to (gnu system pam)....Ludovic Courtès