Make sure, that vtysh_cmd.c is deterministically generated.
--- a/vtysh/extract.pl.in 2017-03-10 13:55:06.000000000 +0100
+++ b/vtysh/extract.pl.in 2017-06-24 00:51:56.460000000 +0200
@@ -214,7 +214,7 @@
}
# Output DEFSH
-foreach (keys %live) {
+foreach (sort keys %live) {
my ($proto);
my ($key);
$key = $live{$_};
@@ -229,7 +229,7 @@
{
EOF
-foreach (keys %odefun) {
+foreach (sort keys %odefun) {
my ($node, $str) = (split (/,/));
$cmd = $ocmd{$_};
$cmd =~ s/_cmd/_cmd_vtysh/;
guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-07-07 | image: Prefer gpt partition table for efi images...* gnu/system/image.scm (efi-disk-image): Use gpt partition-table-type.
(efi32-disk-image): Use gpt partition-table-type.
(qcow2-image-type): Use mbr partition-table-type explicitly.
* gnu/tests/image.scm: Assert partition table type of efi-disk-image.
Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
| Sergey Trofimov |
2022-08-30 | tests: image: New test....Add a new image test module to validate the image creation itself. The images
structures are validated using guile-parted. Checking the content of those
images is out of scope and should be performed in other modules (installation
for instance).
* gnu/tests/image.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
| Mathieu Othacehe |