Fix building with Python 3.9: https://github.com/qtwebkit/qtwebkit/issues/993 Patch copied from upstream source repository: https://github.com/qtwebkit/qtwebkit/commit/78360c01c796b6260bf828bc9c8a0ef73c5132fd From 78360c01c796b6260bf828bc9c8a0ef73c5132fd Mon Sep 17 00:00:00 2001 From: Konstantin Tokarev Date: Wed, 3 Jun 2020 15:01:42 +0300 Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to json.load() In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument is not supported. Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9 --- Source/JavaScriptCore/generate-bytecode-files | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files index c5dab429c7b0f..af3431275ecf9 100644 --- a/Source/JavaScriptCore/generate-bytecode-files +++ b/Source/JavaScriptCore/generate-bytecode-files @@ -163,7 +163,7 @@ if __name__ == "__main__": initBytecodesFile = openOrExit(initASMFileName, "w") try: - bytecodeSections = json.load(bytecodeFile, encoding = "utf-8") + bytecodeSections = json.load(bytecodeFile) except: print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info())) x/commit/tests/guix-package-net.sh?id=49b4d4f70832d0228b004884c12455d16f3a4c6a'>commitdiff
path: root/tests/guix-package-net.sh
AgeCommit message (Expand)Author
2022-01-19package: Honor '--dry-run' when target profile is already in store....Ludovic Courtès
2022-01-16tests: Clean up after 'tests/guix-package-net.sh'....Ludovic Courtès
2020-09-28tests: Simplify shell exit status negation;...Eric Bavier
2020-05-23guix package: Support multiple profiles with '--list-installed'....zimoun
2019-06-14tests: Make builds less expensive....Ludovic Courtès
2019-01-15guix package: '--upgrade' preserves package order....Ludovic Courtès
2017-06-02tests: Remove 't-profile-alt-*-link' files....Ludovic Courtès
2017-01-23guix package: Honor the order of profiles when -p appears multiple times....Ludovic Courtès
2015-11-11guix package: '--search-paths' can report combined search paths....Ludovic Courtès