Age | Commit message (Expand) | Author |
2021-06-10 | gnu: docker: Replace tini by tini-static....The dynamically linked tini could fail in some environments, causing 'docker
run' to exit with the following unhelpful error message:
standard_init_linux.go:219: exec user process caused: no such file or
directory
Use the statically linked tini binary instead, which should work everywhere.
* gnu/packages/docker.scm (docker)[phases]{patch-paths}: Replace 'tini' by
'tini-static'.
| Maxim Cournoyer |
2021-06-10 | gnu: tini: Update to 0.19.0 and provide tini-static....* gnu/packages/docker.scm (tini): Update to 0.19.0. Remove trailing #t.
[phases]: Remove argument.
[configure-flags]: New argument, to clear the CMAKE_INSTALL_RPATH option.
| Maxim Cournoyer |
2021-04-02 | gnu: containerd: Update to 1.4.4....* gnu/packages/docker.scm (containerd): Update to 1.4.4. Delete
trailing #t.
[arguments]: Set a MAKE-FLAGS binding.
[phases]{patch-paths}: Patch the reference to 'unpigz'.
{build, install}: Use the MAKE-FLAGS variable.
[inputs]: Add pigz.
* gnu/packages/patches/containerd-test-with-go1.13.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Un-register it.
| Maxim Cournoyer |
2021-03-11 | gnu: docker-cli: Fix source hash....This is a follow-up to commit 83cda00bc62d665f05d37d07c78a1c4eab5297f0.
* gnu/packages/docker.scm (docker-cli): Fix source hash caused by cascading
%docker-version variable changes.
| Léo Le Bouter |
2021-03-10 | gnu: containerd: Update to 1.3.10 [security fixes]....* gnu/packages/docker.scm (containerd): Update to 1.3.10.
| Léo Le Bouter |
2021-03-10 | gnu: docker: Update to 19.03.15 [security fixes]....* gnu/packages/docker.scm (%docker-version): Bump to 19.03.15.
(docker-libnetwork): Bump to 19.03-1.55e924b.
(docker):
[source]: Set git-reference url to 'https://github.com/moby/moby'.
[arguments]<#:phases>: Modify 'delete-failing-tests phase to delete
'signal_linux_test.go'.
| Léo Le Bouter |
2021-02-08 | gnu: docker: Update to 19.03.13....* gnu/packages/docker.scm (docker, docker-cli): Update to 19.03.13.
| Oleg Pykhalov |