The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles on the GCC internal _GLIBCXX_VISIBILITY macro. Tell it to ignore it as it is not supposed to be looking there to begin with. Upstream report: https://bugreports.qt.io/browse/QTBUG-83160 diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp --- a/src/tools/moc/main.cpp +++ b/src/tools/moc/main.cpp @@ -188,6 +188,7 @@ int runMoc(int argc, char **argv) dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__"); pp.macros["__attribute__"] = dummyVariadicFunctionMacro; pp.macros["__declspec"] = dummyVariadicFunctionMacro; + pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro; QString filename; QString output; Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/size.scm
/tr>
AgeCommit message (Collapse)Author
2020-10-20services: guix: Fix coordinator agent....Mathieu Othacehe
2020-10-08services: guix: Don't use normalized codeset for Guix Data Service....Christopher Baines
2020-10-05services: guix: Add guix-build-coordinator-queue-builds-service-type....Christopher Baines
2020-10-05services: guix: Add guix-build-coordinator-agent-service-type....Christopher Baines
2020-10-05services: guix: Add guix-build-coordinator-service-type....Christopher Baines
2020-03-08services: guix-data-service: Allow passing extra options....Christopher Baines
2019-09-25services: Add the Guix Data Service....Christopher Baines