The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles on the GCC internal _GLIBCXX_VISIBILITY macro. Tell it to ignore it as it is not supposed to be looking there to begin with. Upstream report: https://bugreports.qt.io/browse/QTBUG-83160 diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp --- a/src/tools/moc/main.cpp +++ b/src/tools/moc/main.cpp @@ -188,6 +188,7 @@ int runMoc(int argc, char **argv) dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__"); pp.macros["__attribute__"] = dummyVariadicFunctionMacro; pp.macros["__declspec"] = dummyVariadicFunctionMacro; + pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro; QString filename; QString output; ion value='koszko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix/libutil
AgeCommit message (Expand)Author
2020-06-27daemon: Recognize SHA3 and BLAKE2s....Ludovic Courtès
2020-06-27daemon: Remove OpenSSL hash compatibility wrappers....Ludovic Courtès
2020-06-27daemon: Map directly to gcrypt hash functions....Ludovic Courtès
2020-06-24nix: Tweak .gitignore files....Christopher Baines
2020-03-26daemon: Avoid kill -1 bug on the Hurd....Manolis Ragkousis
2020-01-12daemon: Account for deleted store files when deduplication is on....Ludovic Courtès
2019-11-29daemon: 'pathExists' uses 'statx' when available....Ludovic Courtès
2019-11-27daemon: 'deletePath' uses 'statx' when available....Ludovic Courtès
2019-08-30daemon: Don't reply on 'st_blocks'....Eelco Dolstra
2018-12-16daemon: Use unbranded phrases in comments and messages....Ludovic Courtès
2018-10-02daemon: Remove "case hack" for nars....Ludovic Courtès
2017-08-18nix: Remove unused function....Andy Wingo
2016-05-31daemon: Remove unused XML output code....Ludovic Courtès
2015-12-02daemon: Fix namespace issue.Eelco Dolstra
2015-12-02daemon: Support SHA-512 hashes....Eelco Dolstra
2015-12-02daemon: int2String -> std::to_string.Eelco Dolstra
2015-07-03Merge branch 'nix'....Ludovic Courtès
2015-06-03