The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles on the GCC internal _GLIBCXX_VISIBILITY macro. Tell it to ignore it as it is not supposed to be looking there to begin with. Upstream report: https://bugreports.qt.io/browse/QTBUG-83160 diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp --- a/src/tools/moc/main.cpp +++ b/src/tools/moc/main.cpp @@ -188,6 +188,7 @@ int runMoc(int argc, char **argv) dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__"); pp.macros["__attribute__"] = dummyVariadicFunctionMacro; pp.macros["__declspec"] = dummyVariadicFunctionMacro; + pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro; QString filename; QString output; koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
AgeCommit message (Expand)Author
2020-03-14gnu: pcre: Update to 8.44....* gnu/packages/pcre.scm (pcre): Update to 8.44. Marius Bakke
2019-12-11gnu: pcre2: Do not build static libraries....* gnu/packages/pcre.scm (pcre2)[arguments]: Add "--disable-static" to #:configure-flags. Marius Bakke
2019-12-11gnu: pcre2: Update to 10.34....* gnu/packages/patches/pcre2-fix-jit_match-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/pcre.scm (pcre2): Update to 10.34. [source](patches): Remove. Marius Bakke
2019-08-13Merge branch 'master' into core-updatesMarius Bakke
2019-08-04gnu: Remove pcre2/fixed....* gnu/packages/pcre.scm (pcre2/fixed): Remove variable. (pcre2)[replacement]: Remove. [source](patches): New field. * gnu/packages/php.scm (php)[inputs]: Change PCRE2/FIXED to PCRE2. Marius Bakke
2019-08-02gnu: pcre@2: Fix run-time crash [security fix]....* gnu/packages/pcre.scm (pcre2)[replacement]: New field. (pcre2/fixed): New public variable. * packages/patches/pcre2-fix-jit_match-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Tobias Geerinckx-Rice
2019-05-25Merge branch 'staging' into core-updatesMarius Bakke
2019-05-04gnu: pcre2: Update to 10.33....* gnu/packages/pcre.scm (pcre2): Update to 10.33. Marius Bakke
2019-03-04gnu: pcre: Update to 8.43....* gnu/packages/pcre.scm (pcre): Update to 8.43. Marius Bakke
2019-02-07gnu: pcre2: Update to 10.32....* gnu/packages/pcre.scm (pcre2): Update to 10.32. Marius Bakke