Do not use $ORIGIN in RUNPATH so that executables can be copied elsewhere and still be expected to work (needed for python-pyside-2-tools). diff --git a/mkspecs/common/linux.conf b/mkspecs/common/linux.conf --- a/mkspecs/common/linux.conf +++ b/mkspecs/common/linux.conf @@ -10,8 +10,8 @@ QMAKE_CFLAGS_THREAD += -D_REENTRANT QMAKE_CXXFLAGS_THREAD += $$QMAKE_CFLAGS_THREAD QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections -QMAKE_LFLAGS_REL_RPATH = -Wl,-z,origin -QMAKE_REL_RPATH_BASE = $ORIGIN +QMAKE_LFLAGS_REL_RPATH = +QMAKE_REL_RPATH_BASE = QMAKE_INCDIR = QMAKE_LIBDIR = et'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/chromium-extension.scm
AgeCommit message (Expand)Author
2022-07-20gnu: modifying make-chromium-extension to rely on node-crx3....* gnu/build/chromium-extension.scm (make-crx): Lift Xorg and Chromium dependencies, rely on node-crx3 instead. Signed-off-by: Marius Bakke <marius@gnu.org> Nicolas Graves
2021-12-23chromium-extension: Avoid another usage of the store-mapped /tmp....* gnu/build/chromium-extension.scm (make-crx): Use a Chromium profile relative to the build directory instead of /tmp. While here, remove obsolete comment. Marius Bakke
2021-12-16chromium-extension: Build .crx files in a deterministic fashion....* gnu/build/chromium-extension.scm (make-crx): Pass #:keep-mtime? #t to COPY-RECURSIVELY. Remove defunct FAKETIME workaround. While at it, pack the extension in the scratch working directory instead of the transient store-mapped /tmp. Marius Bakke
2021-12-16chromium-extension: Avoid usage of gcrypt at evaluation time....* gnu/build/chromium-extension.scm (make-signing-key): Wrap builder in with-extensions, and compute the seed checksum at build time. Marius Bakke
2021-12-16chromium-extension: Reduce imported-modules scope....* gnu/build/chromium-extension.scm (make-crx): Delay with-imported-modules until the builder code. (crx->chromium-json): Remove needless define* while at it. Marius Bakke
2021-12-16chromium-extension: Simplify builder code....* gnu/build/chromium-extension.scm (chromium-json->profile-object): Remove variable. (file-sha256): New variable. (make-chromium-extension): Rename OUTPUT parameter to prevent conflict. Adjust other variable names for clarity. [inputs]: Clear. [arguments]: Inline and simplify the final transformation with a gexp. Marius Bakke
2020-11-08Add (gnu build chromium-extension)....* gnu/build/chromium-extension.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. Marius Bakke