Do not use $ORIGIN in RUNPATH so that executables can be copied elsewhere and still be expected to work (needed for python-pyside-2-tools). diff --git a/mkspecs/common/linux.conf b/mkspecs/common/linux.conf --- a/mkspecs/common/linux.conf +++ b/mkspecs/common/linux.conf @@ -10,8 +10,8 @@ QMAKE_CFLAGS_THREAD += -D_REENTRANT QMAKE_CXXFLAGS_THREAD += $$QMAKE_CFLAGS_THREAD QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections -QMAKE_LFLAGS_REL_RPATH = -Wl,-z,origin -QMAKE_REL_RPATH_BASE = $ORIGIN +QMAKE_LFLAGS_REL_RPATH = +QMAKE_REL_RPATH_BASE = QMAKE_INCDIR = QMAKE_LIBDIR = dden' name='id' value='0be51fe03bf2b8f3ef009929fa0860e17aa15de4'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer.scm
AgeCommit message (Collapse)Author
2022-12-05installer: Log provenance data.Ludovic Courtès
* gnu/installer.scm (provenance-sexp): New procedure. (installer-program)[installer-builder]: Add 'installer-log-line' call.
2022-11-15installer: Migrate to 'guile-gnutls'.Ludovic Courtès
* gnu/installer.scm (installer-program): Replace GNUTLS with GUILE-GNUTLS.
2022-11-15installer: Report known-unsupported PCI devices.Ludovic Courtès
* gnu/installer/hardware.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add it. * po/guix/POTFILES.in: Add it. * gnu/installer.scm (installer-steps): Pass #:pci-database to the 'welcome' step procedure. * gnu/installer/newt.scm (welcome-page): Add #:pci-database and pass it to 'run-welcome-page'. * gnu/installer/newt/welcome.scm (check-hardware-support): Add #:pci-database. Enumerate unsupported PCI devices and run an error page when unsupported devices are found. (run-welcome-page): Add #:pci-database and pass it to 'check-hardware-support' and to the recursive call. * gnu/installer/record.scm (<installer>)[welcome-page]: Adjust comment. * doc/guix.texi (Hardware Considerations): Mention it.
2022-11-15installer: Use 'current-guix' for extensions.Ludovic Courtès
This lets us use the latest (gnu build linux-modules) for instance. Note that items listed in 'with-extensions' come first in the load path, before the directory containing the modules in 'with-imported-modules'. * gnu/installer.scm (installer-program): Use (current-guix) instead of 'guix' in 'with-extensions'.
2022-11-02installer: Skip the backtrace page on user abort.Mathieu Othacehe
When the user aborts the installation because a core dump is discovered or the installation command failed, displaying the abort backtrace doesn't make much sense. Hide it when the abort condition is &user-abort-error and skip directly to the dump page. * gnu/installer/steps.scm (&user-abort-error): New variable. (user-abort-error?): New procedure. * gnu/installer/newt/final.scm (run-install-failed-page): Raise a user-abort-error. * gnu/installer/newt/welcome.scm (run-welcome-page): Ditto. * gnu/installer.scm (installer-program): Hide the backtrace page and directly propose to dump the report when the a &user-abort-error is raised.
2022-11-02installer: Add core dump support.Mathieu Othacehe
Fixes: <https://issues.guix.gnu.org/58733> * gnu/installer.scm (installer-program): Enable core dump generation. * gnu/installer/dump.scm (%core-dump): New variable. (prepare-dump): Copy the core dump file. * gnu/installer/newt/welcome.scm (run-welcome-page): Propose to report an installation that previously generated a core dump.
2022-08-08installer: Render the final configuration with (guix read-print).Ludovic Courtès
* gnu/installer.scm (module-to-import?): Return #t for (guix read-print). * gnu/installer/steps.scm (configuration->file): Use 'pretty-print-with-comments/splice' instead of 'for-each' and 'pretty-print'.