Use $TZDIR to search for time-zone data. Thus avoid depending on package "tzdata", which often introduces changes with near-immediate effects, so it's important to be able to update it fast. Based on a patch fron NixOS. =================================================================== --- qtbase-opensource-src-5.14.2.orig/src/corelib/time/qtimezoneprivate_tz.cpp +++ qtbase-opensource-src-5.15.2/src/corelib/time/qtimezoneprivate_tz.cpp @@ -70,7 +70,11 @@ // Parse zone.tab table, assume lists all installed zones, if not will need to read directories static QTzTimeZoneHash loadTzTimeZones() { - QString path = QStringLiteral("/usr/share/zoneinfo/zone.tab"); + // Try TZDIR first, in case we're running on GuixSD. + QString path = QFile::decodeName(qgetenv("TZDIR")) + QStringLiteral("/zone.tab"); + // Fallback to traditional paths in case we are not on GuixSD. + if (!QFile::exists(path)) + path = QStringLiteral("/usr/share/zoneinfo/zone.tab"); if (!QFile::exists(path)) path = QStringLiteral("/usr/lib/zoneinfo/zone.tab"); @@ -645,6 +649,9 @@ if (!tzif.open(QIODevice::ReadOnly)) return; } else { + // Try TZDIR first, in case we're running on GuixSD. + tzif.setFileName(QFile::decodeName(qgetenv("TZDIR")) + QStringLiteral("/") + QString::fromLocal8Bit(ianaId)); + if (!tzif.open(QIODevice::ReadOnly)) { // Open named tz, try modern path first, if fails try legacy path tzif.setFileName(QLatin1String("/usr/share/zoneinfo/") + QString::fromLocal8Bit(ianaId)); if (!tzif.open(QIODevice::ReadOnly)) { @@ -652,6 +659,7 @@ if (!tzif.open(QIODevice::ReadOnly)) return; } + } } QDataStream ds(&tzif); >
path: root/doc/local.mk
AgeCommit message (Expand)Author
2024-06-03nls: Update translations....Florian Pelz
2024-06-03build: Use the po4a command for the translation generation....gemmaro
2024-04-19Revert "maint: Generate 'doc/version.texi' reproducibly."...Janneke Nieuwenhuizen
2024-04-19Revert "maint: Generate 'doc/version-LANG.texi' reproducibly."...Janneke Nieuwenhuizen
2024-04-14maint: Ensure generated file reproducibility for dist....Janneke Nieuwenhuizen
2024-04-14maint: Reset CreationDate metadata on generated PDFs....Janneke Nieuwenhuizen
2024-04-14maint: Avoid PNG and PDF generation to fail silently....Janneke Nieuwenhuizen
2024-04-14maint: Avoid EPS generation to fail silently, ensure reproducibility....Janneke Nieuwenhuizen
2024-04-14maint: Generate 'doc/version-LANG.texi' reproducibly....Janneke Nieuwenhuizen
2024-04-14maint: Help help2man generate reproducible man-pages....Janneke Nieuwenhuizen
2024-04-14maint: Generate 'doc/version.texi' reproducibly....Timothy Sample
2024-04-03maint: Fix help2man for guix subcommands with `make V=2'....Janneke Nieuwenhuizen
2024-04-01nls: Update translations....Florian Pelz
2023-08-29doc: Fix a potential problem in man page generation rule....Maxim Cournoyer
2023-08-25build: Add dependency on guix script for help2man targets....Josselin Poiret