http://git.qemu.org/?p=qemu.git;a=patch;h=8409dc884a201bf74b30a9d232b6bbdd00cb7e2b this patch is from qemu-git. From 8409dc884a201bf74b30a9d232b6bbdd00cb7e2b Mon Sep 17 00:00:00 2001 From: Li Qiang Date: Wed, 4 Jan 2017 00:43:16 -0800 Subject: [PATCH] serial: fix memory leak in serial exit The serial_exit_core function doesn't free some resources. This can lead memory leak when hotplug and unplug. This patch avoid this. Signed-off-by: Li Qiang Message-Id: <586cb5ab.f31d9d0a.38ac3.acf2@mx.google.com> Signed-off-by: Paolo Bonzini --- hw/char/serial.c | 10 ++++++++++ 1 file changed, 10 insertions(+) diff --git a/hw/char/serial.c b/hw/char/serial.c index ffbacd8227..67b18eda12 100644 --- a/hw/char/serial.c +++ b/hw/char/serial.c @@ -906,6 +906,16 @@ void serial_realize_core(SerialState *s, Error **errp) void serial_exit_core(SerialState *s) { qemu_chr_fe_deinit(&s->chr); + + timer_del(s->modem_status_poll); + timer_free(s->modem_status_poll); + + timer_del(s->fifo_timeout_timer); + timer_free(s->fifo_timeout_timer); + + fifo8_destroy(&s->recv_fifo); + fifo8_destroy(&s->xmit_fifo); + qemu_unregister_reset(serial_reset, s); } -- 2.11.0 0e823a26660235928cdfa00a4024cf43a'>treecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 00:27:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 09:29:44 -0400
commitf995f710e823a26660235928cdfa00a4024cf43a (patch)
treec99208d5345f58ecf0e9ef2b01bc99fee10a2d59
parenta23789bbbdd23b1130f0f2521ee8d68872b7fc2c (diff)
downloadguix-f995f710e823a26660235928cdfa00a4024cf43a.tar.gz
guix-f995f710e823a26660235928cdfa00a4024cf43a.zip
build: Replace the doc-po-update prerequisite by doc-pot-update.
What is really required for the dist target is the presence of the auto-generated .pot files; updating the PO files is not necessary nor desirable (it causes spurious changes in the tree). * Makefile.am (dist) <doc-po-update>: Replace prerequisite with... <doc-pot-update>: ... this one.
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 941ab05234..de32a0a42b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -740,9 +740,9 @@ guix-binary.%.tar.xz:
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
-# The dependency on doc-po-update is to generate the .pot files, which are not
-# checked in.
-dist: doc-po-update
+# The dependency on doc-pot-update is to generate the .pot files, which are
+# not checked in.
+dist: doc-pot-update
dist-hook: gen-ChangeLog gen-AUTHORS gen-tarball-version
dist-hook: assert-no-store-file-names