This test tries to send a KeyboardInterrupt, which does
not work in the build environment.
--- a/test_subprocess32.py 2017-03-06 22:21:49.334045485 +0100
+++ b/test_subprocess32.py 2017-03-06 22:22:02.490439949 +0100
@@ -1299,12 +1299,6 @@
getattr(p, method)(*args)
return p
- def test_send_signal(self):
- p = self._kill_process('send_signal', signal.SIGINT)
- _, stderr = p.communicate()
- self.assertIn('KeyboardInterrupt', stderr)
- self.assertNotEqual(p.wait(), 0)
-
def test_kill(self):
p = self._kill_process('kill')
_, stderr = p.communicate()
5e1eeb869870c2c1dabe9'/>
installer: connman: Fix Wifi connection....Issue reported by SergioBG here:
https://lists.gnu.org/archive/html/bug-guix/2020-04/msg00432.html.
Due to default buffering mode, the installer was reading from the pipe without
having actually written a command before.
* gnu/installer/connman.scm (connman-connect-with-auth): Set pipe buffering
mode to 'line.
Mathieu Othacehe
2019-05-29
installer: Fix wifi menu crash with hidden SSIDs....This fixes https://issues.guix.gnu.org/issue/35622.
* gnu/installer/connman.scm (<service>): Mention that name may be false.
* gnu/installer/newt/wifi.scm (wifi-services): Filter out wifi services
without name.
Co-authored by: Pierre Neidhardt <mail@ambrevar.xyz>