Skip test that requires getaddrinfo(), which is not available in the build
environment. This package uses a regexp for finding tests (see runner.py),
so using @unittest.skip does not work.
--- a/waitress/tests/test_adjustments.py
+++ b/waitress/tests/test_adjustments.py
@@ -185,22 +185,6 @@
def test_bad_port(self):
self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
- def test_service_port(self):
- if WIN and PY2: # pragma: no cover
- # On Windows and Python 2 this is broken, so we raise a ValueError
- self.assertRaises(
- ValueError,
- self._makeOne,
- listen='127.0.0.1:http',
- )
- return
-
- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
-
- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
-
- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
-
def test_dont_mix_host_port_listen(self):
self.assertRaises(
ValueError,
/'>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-09-08 | privilege: Add file-like->setuid-program helper....* gnu/system/privilege.scm (file-like->setuid-program): New public
procedure.
* gnu/system/setuid.scm: Re-export it for compatibility.
(file-like->setuid-program): Remove this old version.
* gnu/services/docker.scm (singularity-setuid-programs): Use it (again).
* gnu/services/desktop.scm (enlightenment-privileged-programs): Likewise.
Change-Id: I8e41144438677a15cdadb3063651dbc780715497
| Tobias Geerinckx-Rice |
2024-08-11 | system: (gnu system setuid) wraps (gnu system privilege)....* gnu/system/setuid.scm (setuid-program): Rewrite as syntax to create a
<privileged-program> record that is setuid by default.
(setuid-program?, setuid-program-program, setuid-program-setuid?)
(setuid-program-setgid?, setuid-program-user, setuid-program-group):
Alias their privileged-program equivalent.
| Tobias Geerinckx-Rice |
2021-07-29 | system: Add (gnu system setuid)....I flubbed and somehow when including the patch series, this got dropped.
Oops... should fix things again.
* gnu/system/setuid.scm: New file.
| Christopher Lemmer Webber |