Skip test that requires getaddrinfo(), which is not available in the build
environment. This package uses a regexp for finding tests (see runner.py),
so using @unittest.skip does not work.
--- a/waitress/tests/test_adjustments.py
+++ b/waitress/tests/test_adjustments.py
@@ -185,22 +185,6 @@
def test_bad_port(self):
self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
- def test_service_port(self):
- if WIN and PY2: # pragma: no cover
- # On Windows and Python 2 this is broken, so we raise a ValueError
- self.assertRaises(
- ValueError,
- self._makeOne,
- listen='127.0.0.1:http',
- )
- return
-
- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
-
- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
-
- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
-
def test_dont_mix_host_port_listen(self):
self.assertRaises(
ValueError,
maryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-02-22 | packages: 'package-field-location' handles 'search-path' returning #f....Fixes <https://bugs.gnu.org/46390>.
Reported by zimoun <zimon.toutoune@gmail.com>.
This is similar to the fix in d10474c38d58bdc676e64336769dc2e00cdfa8ed.
* guix/packages.scm (package-field-location): Handle FILE not in %LOAD-PATH.
* tests/guix-lint.sh: Add test.
| Ludovic Courtès |
2020-09-28 | tests: Simplify shell exit status negation;...* tests/guix-archive.sh, tests/guix-build-branch.sh, tests/guix-build.sh,
tests/guix-daemon.sh, tests/guix-download.sh, tests/guix-environment.sh,
tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh,
tests/guix-hash.sh, tests/guix-lint.sh, tests/guix-pack-relocatable.sh,
tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh,
tests/guix-package.sh: Use the shell '!' keyword to negate command exit status
in place of 'if ...; then false; else true; fi'
| Eric Bavier |
2020-08-23 | lint: formatting: Gracefully handle relative file names....Fixes <https://bugs.gnu.org/42543>.
Reported by Jack Hill <jackhill@jackhill.us>.
* guix/lint.scm (check-formatting): Always return a list (previously we
would return #f when 'search-path' returns #f). Check whether
LOCATION's file is a relative file name. Return a warning if not.
* tests/guix-lint.sh: Add test.
| Ludovic Courtès |
2019-12-08 | lint: Add '--load-path' option....* guix/scripts/lint.scm (%options): Add '--load-path' option.
* doc/guix.texi: Document it.
* tests/guix-lint.sh: Test it.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| zimoun |