Taken from Gentoo, which adapted
https://github.com/agronholm/typeguard/commit/e0db07a777d5a481eaba6162354adf32286ce21b
diff --git a/src/typeguard/__init__.py b/src/typeguard/__init__.py
index 5684d63..27fa30b 100644
--- a/src/typeguard/__init__.py
+++ b/src/typeguard/__init__.py
@@ -61,22 +61,25 @@ except ImportError:
from typing import _ForwardRef as ForwardRef
evaluate_forwardref = ForwardRef._eval_type
-if sys.version_info >= (3, 10):
- from typing import is_typeddict
-else:
- _typed_dict_meta_types = ()
- if sys.version_info >= (3, 8):
- from typing import _TypedDictMeta
- _typed_dict_meta_types += (_TypedDictMeta,)
+try:
+ from typing_extensions import is_typeddict
+except ImportError:
+ if sys.version_info >= (3, 10):
+ from typing import is_typeddict
+ else:
+ _typed_dict_meta_types = ()
+ if sys.version_info >= (3, 8):
+ from typing import _TypedDictMeta
+ _typed_dict_meta_types += (_TypedDictMeta,)
- try:
- from typing_extensions import _TypedDictMeta
- _typed_dict_meta_types += (_TypedDictMeta,)
- except ImportError:
- pass
+ try:
+ from typing_extensions import _TypedDictMeta
+ _typed_dict_meta_types += (_TypedDictMeta,)
+ except ImportError:
+ pass
- def is_typeddict(tp) -> bool:
- return isinstance(tp, _typed_dict_meta_types)
+ def is_typeddict(tp) -> bool:
+ return isinstance(tp, _typed_dict_meta_types)
if TYPE_CHECKING:
f3b10dad17f157378'>diff
|
Age | Commit message (Expand) | Author |
2022-06-16 | shell: Fix '--export-manifest' for cached profiles and when '-p' is used....Fixes <https://issues.guix.gnu.org/55521>.
* guix/scripts/shell.scm (export-manifest): When computing 'manifest',
honor the 'profile key.
* tests/guix-shell-export-manifest.sh: Add test.
| Ludovic Courtès |
2022-06-01 | shell: '--export-manifest -D x -D y' generates a valid manifest....* guix/scripts/shell.scm (manifest->code*): Add missing 'list' in
generated 'concatenate-manifests' call.
* tests/guix-shell-export-manifest.sh: Add test.
| Ludovic Courtès |
2022-04-08 | tests: 'guix shell --export-manifest' test no longer needs networking....* tests/guix-shell-export-manifest.sh: Use '--with-input' rather than
'--with-latest' as the latter would crash in the absence of network
access.
| Ludovic Courtès |
2022-04-04 | shell: Add '--export-manifest'....* guix/scripts/shell.scm (show-help, %options): Add '--export-manifest'.
(manifest-entry-version-prefix, manifest->code*)
(export-manifest): New procedures.
(guix-shell): Honor '--export-manifest'.
* tests/guix-shell-export-manifest.sh: New file.
* Makefile.am (SH_TESTS): Add it.
* doc/guix.texi (Invoking guix shell): Document '--export-manifest'.
(Invoking guix environment): Link to it.
(Invoking guix pack): Likewise.
| Ludovic Courtès |