This drops a test that fails with numpy 1.12.
Upstream bug URL: https://github.com/statsmodels/statsmodels/issues/3541
--- a/statsmodels/discrete/tests/test_discrete.py 2017-03-06 15:29:19.947343331 +0000
+++ b/statsmodels/discrete/tests/test_discrete.py 2017-03-06 15:29:37.759328845 +0000
@@ -1329,21 +1329,6 @@
res = mod.fit(start_params=-np.ones(4), method='newton', disp=0)
assert_(not res.mle_retvals['converged'])
-def test_issue_339():
- # make sure MNLogit summary works for J != K.
- data = sm.datasets.anes96.load()
- exog = data.exog
- # leave out last exog column
- exog = exog[:,:-1]
- exog = sm.add_constant(exog, prepend=True)
- res1 = sm.MNLogit(data.endog, exog).fit(method="newton", disp=0)
- # strip the header from the test
- smry = "\n".join(res1.summary().as_text().split('\n')[9:])
- cur_dir = os.path.dirname(os.path.abspath(__file__))
- test_case_file = os.path.join(cur_dir, 'results', 'mn_logit_summary.txt')
- test_case = open(test_case_file, 'r').read()
- np.testing.assert_equal(smry, test_case[:-1])
-
def test_issue_341():
data = sm.datasets.anes96.load()
exog = data.exog
41ac60aee2f5d31'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2024-12-12 | build: Fix detection of guile-ssh....Fixes <https://issues.guix.gnu.org/74800>.
The check for make-session stopped working after update to 0.18.0. This
commit adds the additional `#:config #f' to skip reading the ssh
configuration, arguably we did not want to do that anyway.
* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Add `#:config #f' to make-session call.
Change-Id: Id6ea3860292159ac2e6cf2a77df5f720f66aa071
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Reported-by: Dariqq <dariqq@posteo.net>
| Tomas Volf |
2024-12-03 | gnu: bootstrap: Add support for x86_64-gnu, aka the 64bit Hurd....On commit:
ec8a5ec15f898e864705e5a5c834532e3fa8d0a4
gnu: make-bootstrap: Update gcc-static to gcc-14, for the 64bit Hurd.
Run:
./pre-inst-env guix build --target=x86_64-gnu bootstrap-tarballs
Producing:
/gnu/store/w1n7bdpn88plcc49h7n0jriaj41sgwx8-bootstrap-tarballs-0/
With guix hash -r:
15cb1xh7s2hhp8s0d81bjnw1759w9sh7ckc9n5jq2f3rqw6z76by
* gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for
x86_64-gnu.
(%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils,
%bootstrap-glibc, %bootstrap-gcc): Add entry for x86_64-gnu.
* guix/packages.scm (%supported-systems, %hurd-systems): Add x86_64-gnu.
(%cuirass-supported-systems): Remove x86_64-gnu.
* guix/utils.scm (target-64bit?): Add x86_64-gnu.
* m4/guix.m4: Add x86_64-gnu as a supported system.
* doc/guix.texi (GNU Distribution): Add x86_64-gnu.
Change-Id: I828159aedb3f66caba98e935083cc3682429f219
| Janneke Nieuwenhuizen |
2023-11-07 | build: Fix spelling in m4 macros....* m4/guix.m4 (GUIX_CHECK_GUILE_SSH): Fix spelling of parameter.
(GUIX_CHECK_FILE_NAME_LIMITS): Fix spelling of maximum.
Change-Id: I93c80441393622a4bc06daa475eee13874cca527
| Efraim Flashner |