Add an environment variable to python-sip that extends its search
directories for .sip files.
It seems that we cannot easily change the destination folder of these
files though, so this variable must be set on a per-package basis (and
non through search-path).
--- sip/sipbuild/builder.py 2023-03-22 09:06:37.588792878 +0100
+++ sip/sipbuild/builder.py 2023-03-22 09:10:35.830181134 +0100
@@ -254,6 +254,10 @@
os.path.join(project.target_dir,
project.get_bindings_dir()))
+ # Add extra bindings from environment for GNU Guix.
+ if 'SIP_INCLUDE_DIRS' in os.environ:
+ sip_include_dirs.extend(os.environ['SIP_INCLUDE_DIRS'].split(os.pathsep))
+
# Generate the sip.h file for the shared sip module.
copy_sip_h(abi_major_version, project.build_dir,
project.sip_module, version_info=project.version_info)
ub right'>
Age | Commit message (Expand) | Author |
2022-07-12 | guix: Really export 'define-public'....This is a followup to 3858275962f1ac567b5dce2355035f9eddea0a05, which
didn't have any effect.
* guix.scm: Explicitly use (guix packages) so #:re-export-and-replace
is effective.
| Ludovic Courtès |
2021-09-14 | guix: Replace 'define-public'....This is a followup to 8531997d2a1e10d574a6e9ab70bc86ade6af4733.
* guix.scm: Use #:re-export-and-replace for 'define-public'.
| Ludovic Courtès |
2021-06-29 | (guix) no longer pulls in (guix ftp-client)....That choice was made in 2014 and never made much sense.
* guix.scm (%public-modules): Remove 'ftp-client'.
| Ludovic Courtès |