Add an environment variable to python-sip that extends its search
directories for .sip files.
It seems that we cannot easily change the destination folder of these
files though, so this variable must be set on a per-package basis (and
non through search-path).
--- sip/sipbuild/builder.py 2023-03-22 09:06:37.588792878 +0100
+++ sip/sipbuild/builder.py 2023-03-22 09:10:35.830181134 +0100
@@ -254,6 +254,10 @@
os.path.join(project.target_dir,
project.get_bindings_dir()))
+ # Add extra bindings from environment for GNU Guix.
+ if 'SIP_INCLUDE_DIRS' in os.environ:
+ sip_include_dirs.extend(os.environ['SIP_INCLUDE_DIRS'].split(os.pathsep))
+
# Generate the sip.h file for the shared sip module.
copy_sip_h(abi_major_version, project.build_dir,
project.sip_module, version_info=project.version_info)
k's customized Guix
|
Age | Commit message (Expand) | Author |
2023-08-29 | home: services: dicod, syncthing: Import (gnu home services shepherd)....Fixes <https://issues.guix.gnu.org/65510>.
Without this import, 'shepherd-service-type' is not mapped, leading to
an error about missing 'system' target.
* gnu/home/services/dict.scm,
gnu/home/services/syncthing.scm: Add #:use-module clause.
Reported-by: Morgan Smith <Morgan.J.Smith@outlook.com>
| Ludovic Courtès |
2023-08-20 | home: services: Add dicod....* gnu/home/services/dict.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* gnu/services/dict.scm (<dicod-configuration>)[home-service?]: New
field.
(dicod-shepherd-service): Do not map /dev/log when 'home-service?' is
true. Remove 'user-processes' requirement when 'home-service?' is
true.
(dicod-shepherd-service): Set #:user and #:group to #f when
'home-service?' is true.
* doc/guix.texi (Miscellaneous Home Services): New node.
(Miscellaneous Services): Add cross-reference.
| Ludovic Courtès |