Libraries (such as 'libtorch_cpu.so') and executables (such as 'torch_shm_manager') get installed, quite surprisingly, to 'lib/python3.8/site-packages/{bin,lib}'. Make sure RUNPATH matches that. diff --git a/caffe2/CMakeLists.txt b/caffe2/CMakeLists.txt index 5b5622f0..30d27e57 100644 --- a/caffe2/CMakeLists.txt +++ b/caffe2/CMakeLists.txt @@ -1909,7 +1909,7 @@ if(BUILD_PYTHON) if(${BUILDING_WITH_TORCH_LIBS}) # site-packages/caffe2/python/caffe2_pybind11_state # site-packages/torch/lib - set(caffe2_pybind11_rpath "${_rpath_portable_origin}/../../torch/lib") + set(caffe2_pybind11_rpath $ORIGIN/../../torch/lib) endif(${BUILDING_WITH_TORCH_LIBS}) # Must also include `CMAKE_SHARED_LINKER_FLAGS` in linker flags for diff --git a/cmake/Dependencies.cmake b/cmake/Dependencies.cmake index ee9cf410..f190e69b 100644 --- a/cmake/Dependencies.cmake +++ b/cmake/Dependencies.cmake @@ -4,7 +4,7 @@ if(APPLE) set(CMAKE_MACOSX_RPATH ON) set(_rpath_portable_origin "@loader_path") else() - set(_rpath_portable_origin $ORIGIN) + set(_rpath_portable_origin $ORIGIN/../lib) endif(APPLE) # Use separate rpaths during build and install phases set(CMAKE_SKIP_BUILD_RPATH FALSE) ree/nix/libutil?id=67de1fc87be8bb68c1d4e5211cb3e36a8acb9113'>treecommitdiff
path: root/nix/libutil
AgeCommit message (Expand)Author
2020-12-08daemon: 'Agent' constructor takes a list of environment variables....Ludovic Courtès
2020-09-14daemon: Move 'Agent' to libutil....Ludovic Courtès
2020-06-27daemon: Recognize SHA3 and BLAKE2s....Ludovic Courtès
2020-06-27daemon: Remove OpenSSL hash compatibility wrappers....Ludovic Courtès
2020-06-27daemon: Map directly to gcrypt hash functions....Ludovic Courtès
2020-06-24nix: Tweak .gitignore files....Christopher Baines
2020-03-26daemon: Avoid kill -1 bug on the Hurd....Manolis Ragkousis
2020-01-12daemon: Account for deleted store files when deduplication is on....Ludovic Courtès
2019-11-29daemon: 'pathExists' uses 'statx' when available....Ludovic Courtès
2019-11-27daemon: 'deletePath' uses 'statx' when available....Ludovic Courtès
2019-08-30daemon: Don't reply on 'st_blocks'....Eelco Dolstra
2018-12-16daemon: Use unbranded phrases in comments and messages....Ludovic Courtès
2018-10-02daemon: Remove "case hack" for nars....Ludovic Courtès
2017-08-18nix: Remove unused function....Andy Wingo