Libraries (such as 'libtorch_cpu.so') and executables (such as 'torch_shm_manager')
get installed, quite surprisingly, to 'lib/python3.8/site-packages/{bin,lib}'.
Make sure RUNPATH matches that.
diff --git a/caffe2/CMakeLists.txt b/caffe2/CMakeLists.txt
index 5b5622f0..30d27e57 100644
--- a/caffe2/CMakeLists.txt
+++ b/caffe2/CMakeLists.txt
@@ -1909,7 +1909,7 @@ if(BUILD_PYTHON)
if(${BUILDING_WITH_TORCH_LIBS})
# site-packages/caffe2/python/caffe2_pybind11_state
# site-packages/torch/lib
- set(caffe2_pybind11_rpath "${_rpath_portable_origin}/../../torch/lib")
+ set(caffe2_pybind11_rpath $ORIGIN/../../torch/lib)
endif(${BUILDING_WITH_TORCH_LIBS})
# Must also include `CMAKE_SHARED_LINKER_FLAGS` in linker flags for
diff --git a/cmake/Dependencies.cmake b/cmake/Dependencies.cmake
index ee9cf410..f190e69b 100644
--- a/cmake/Dependencies.cmake
+++ b/cmake/Dependencies.cmake
@@ -4,7 +4,7 @@ if(APPLE)
set(CMAKE_MACOSX_RPATH ON)
set(_rpath_portable_origin "@loader_path")
else()
- set(_rpath_portable_origin $ORIGIN)
+ set(_rpath_portable_origin $ORIGIN/../lib)
endif(APPLE)
# Use separate rpaths during build and install phases
set(CMAKE_SKIP_BUILD_RPATH FALSE)
x/log/gnu/packages/cross-toolchain.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-12-11 | gnu: Add gcc-cross-x86_64-w64-mingw32-toolchain....* gnu/packages/cross-toolchain.scm (gcc-cross-x86_64-w64-mingw32-toolchain):
New variable.
Change-Id: I94802e5e7cb218d7afb0ee09871125bae5db933c
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Jean-Pierre De Jesus DIAZ |
2023-12-11 | gnu: Add gcc-cross-i686-w64-mingw32-toolchain....* gnu/packages/cross-toolchain.scm (gcc-cross-i686-w64-mingw32-toolchain):
New variable.
Change-Id: I5d6056fc4943acae03aeaafa587f40ced182b1d4
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Jean-Pierre De Jesus DIAZ |
2023-12-11 | gnu: Add gcc-cross-avr-toolchain....* gnu/local.mk (GNU_SYSTEM_MODULES): Add cross-toolchain.scm.
* gnu/packages/cross-toolchain.scm (gcc-cross-avr-toolchain): New variable.
Change-Id: Ie768d5cc0663dd57753af1d4ac631b3cafbf9e8c
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
| Jean-Pierre De Jesus DIAZ |