This test incorrectly assumes that the root user is always available.
However, in the build environment, the root user is not available.
Note that because the original file distributed in the release on PyPi
has lines ending in CRLF, those are retained in the diff below.
--- a/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
+++ b/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
@@ -1021,15 +1021,6 @@
self.assertEqual(self.path.expanduser('~'),
self.os.environ['HOME'].replace('/', '!'))
- @unittest.skipIf(TestCase.is_windows or TestCase.is_cygwin,
- 'only tested on unix systems')
- def test_expand_root(self):
- if sys.platform == 'darwin':
- roothome = '!var!root'
- else:
- roothome = '!root'
- self.assertEqual(self.path.expanduser('~root'), roothome)
-
def test_getsize_path_nonexistent(self):
file_path = 'foo!bar!baz'
self.assertRaises(os.error, self.path.getsize, file_path)
x/refs/?id=ac6fec05e4fe6b615651ea3e7c36f5a542cfa400'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2017-01-31 | gnu: Add JOE....* gnu/packages/text-editors.scm (joe): New variable.
| Eric Bavier |
2017-01-27 | gnu: kakoune: Move reproducibility substitution to source snippet....* gnu/packages/text-editors.scm (kakoune)[arguments]: Move substitution to ...
[source]: ... here.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Carlo Zancanaro |
2017-01-26 | gnu: text-editors.scm: Fix imports....This is a followup to 5613ea79fccc5a5befafea313cb81010c5f5a8dd.
* gnu/packages/text-editors.scm: Import (gnu packages terminals).
| Marius Bakke |
2017-01-26 | gnu: Add kakoune....* gnu/packages/text-editors.scm (kakoune): New variable.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| Carlo Zancanaro |
2016-12-08 | gnu: Add vis....* gnu/packages/text-editors.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Co-authored-by: Marius Bakke <mbakke@fastmail.com>
| José Miguel Sánchez García |