This test incorrectly assumes that the root user is always available. However, in the build environment, the root user is not available. Note that because the original file distributed in the release on PyPi has lines ending in CRLF, those are retained in the diff below. --- a/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800 +++ b/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800 @@ -1021,15 +1021,6 @@ self.assertEqual(self.path.expanduser('~'), self.os.environ['HOME'].replace('/', '!')) - @unittest.skipIf(TestCase.is_windows or TestCase.is_cygwin, - 'only tested on unix systems') - def test_expand_root(self): - if sys.platform == 'darwin': - roothome = '!var!root' - else: - roothome = '!root' - self.assertEqual(self.path.expanduser('~root'), roothome) - def test_getsize_path_nonexistent(self): file_path = 'foo!bar!baz' self.assertRaises(os.error, self.path.getsize, file_path) 9da127035737bdf922bc566970c5506c2e01b00'>refslogtreecommitdiff
path: root/gnu/packages/mtools.scm
AgeCommit message (Expand)Author
2019-04-21gnu: mtools: 'mformat' initializes boot sector before writing it....This is the last bit fixing <https://bugs.gnu.org/35283>. Previously, 'mformat' (used by 'grub-mkrescue') would pass uninitialized bytes to write(2), leading to non-deterministic FAT image contents. This patch fixes that. * gnu/packages/patches/mtools-mformat-uninitialized.patch: New file. * gnu/packages/mtools.scm (mtools)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Ludovic Courtès
2018-12-10gnu: mtools: Update to 4.0.23....* gnu/packages/mtools.scm (mtools): Update to 4.0.23. Efraim Flashner
2018-12-09gnu: mtools: Update to 4.0.22....* gnu/packages/mtools.scm (mtools): Update to 4.0.22. Efraim Flashner
2018-11-25gnu: mtools: Update to 4.0.21....* gnu/packages/mtools.scm (mtools): Update to 4.0.21. Efraim Flashner
2018-11-14gnu: mtools: Update to 4.0.20....* gnu/packages/mtools.scm (mtools): Update to 4.0.20. [source](uri): Change to 'bz2' compressed tarball. Marius Bakke
2018-09-30gnu: mtools: Update to 4.0.19....* gnu/packages/mtools.scm (mtools): Update to 4.0.19. Efraim Flashner
2018-09-18gnu: exfat-utils: Update to 1.3.0....* gnu/packages/mtools.scm (exfat-utils): Update to 1.3.0. Tobias Geerinckx-Rice
2018-02-10gnu: exfat-utils: Update to 1.2.8....* gnu/packages/mtools.scm (exfat-utils): Update to 1.2.8. Tobias Geerinckx-Rice