This test incorrectly assumes that the root user is always available.
However, in the build environment, the root user is not available.
Note that because the original file distributed in the release on PyPi
has lines ending in CRLF, those are retained in the diff below.
--- a/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
+++ b/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800
@@ -1021,15 +1021,6 @@
self.assertEqual(self.path.expanduser('~'),
self.os.environ['HOME'].replace('/', '!'))
- @unittest.skipIf(TestCase.is_windows or TestCase.is_cygwin,
- 'only tested on unix systems')
- def test_expand_root(self):
- if sys.platform == 'darwin':
- roothome = '!var!root'
- else:
- roothome = '!root'
- self.assertEqual(self.path.expanduser('~root'), roothome)
-
def test_getsize_path_nonexistent(self):
file_path = 'foo!bar!baz'
self.assertRaises(os.error, self.path.getsize, file_path)
864dba82e14895afbe841091091366c96bc'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2019-03-01 | gnu: attr: Update to 2.4.48....* gnu/packages/attr.scm (attr): Update to 2.4.48.
[source](uri): Adjust for renamed tarball.
[arguments]: Remove obsolete phases.
[license]: Remove GPL2+ (see upstream commit 0fb61a4d20).
| Marius Bakke |
2018-03-16 | gnu: attr: Use invoke instead of system*....* gnu/packages/attr.scm (attr)[arguments]: Use invoke. Return a boolean from
all phase procedures. Add a comment explaining why one call to system* is
retained.
| Mark H Weaver |
2018-02-16 | gnu: Use HTTPS for supported nongnu.org home pages....* gnu/packages/acl.scm (acl)[home-page]: Use HTTPS.
* gnu/packages/admin.scm (dmidecode)[home-page]: Likewise.
* gnu/packages/attr.scm (attr)[home-page]: Likewise.
* gnu/packages/audio.scm (lash)[home-page]: Likewise.
* gnu/packages/avr.scm (avr-libc)[home-page]: Likewise.
* gnu/packages/backup.scm (rdiff-backup, libchop)[home-page]: Likewise.
* gnu/packages/compression.scm (fastjar, lzip, lziprecover, atool)
(lunzip, clzip, lzlib, plzip)[home-page]: Likewise.
* gnu/packages/emacs.scm (geiser, bbdb, m17n-lib, m17n-lib)[home-page]:
Likewise.
* gnu/packages/flashing-tools.scm (avrdude)[home-page]: Likewise.
* gnu/packages/fontutils.scm (libotf)[home-page]: Likewise.
* gnu/packages/game-development.scm (gzochi)[home-page]: Likewise.
* gnu/packages/games.scm (enigma)[home-page]: Likewise.
* gnu/packages/gsasl.scm (libntlm)[home-page]: Likewise.
* gnu/packages/gtk.scm (guile-cairo)[home-page]: Likewise.
* gnu/packages/guile.scm (guile-reader, guile-lib, guile-json)
(guile-redis, g-wrap)[home-page]: Likewise.
* gnu/packages/libunwind.scm (libunwind)[home-page]: Likewise.
* gnu/packages/lout.scm (lout)[home-page]: Likewise.
* gnu/packages/mpd.scm (sonata)[home-page]: Likewise.
* gnu/packages/networking.scm (quagga)[home-page]: Likewise.
* gnu/packages/ratpoison.scm (ratpoison)[home-page]: Likewise.
* gnu/packages/skribilo.scm (skribilo)[home-page]: Likewise.
* gnu/packages/telephony.scm (exosip)[home-page]: Likewise.
* gnu/packages/texinfo.scm (texi2html)[home-page]: Likewise.
* gnu/packages/xdisorg.scm (xbindkeys)[home-page]: Likewise.
| Tobias Geerinckx-Rice |