This test incorrectly assumes that the root user is always available. However, in the build environment, the root user is not available. Note that because the original file distributed in the release on PyPi has lines ending in CRLF, those are retained in the diff below. --- a/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800 +++ b/pyfakefs/tests/fake_filesystem_test.py 1969-12-31 16:00:00.000000000 -0800 @@ -1021,15 +1021,6 @@ self.assertEqual(self.path.expanduser('~'), self.os.environ['HOME'].replace('/', '!')) - @unittest.skipIf(TestCase.is_windows or TestCase.is_cygwin, - 'only tested on unix systems') - def test_expand_root(self): - if sys.platform == 'darwin': - roothome = '!var!root' - else: - roothome = '!root' - self.assertEqual(self.path.expanduser('~root'), roothome) - def test_getsize_path_nonexistent(self): file_path = 'foo!bar!baz' self.assertRaises(os.error, self.path.getsize, file_path) efs/?id=38704987067ba365d0d5d18095eaa0bd0a0da2ce'>refslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAaron Covrig <aaron.covrig.us@ieee.org>2024-04-05 20:44:38 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:46:56 +0300
commit38704987067ba365d0d5d18095eaa0bd0a0da2ce (patch)
tree11b8d36e201fcb5a16c314b74a350294a8581443 /gnu/packages
parente5a1bdfa29ca22c15c5a9c1058fa62ecdabefc08 (diff)
downloadguix-38704987067ba365d0d5d18095eaa0bd0a0da2ce.tar.gz
guix-38704987067ba365d0d5d18095eaa0bd0a0da2ce.zip
gnu: Add rust-devise-0.3.
* gnu/packages/crates-io.scm (rust-devise-0.3): New variable. Signed-off-by: Aaron Covrig <aaron.covrig.us@ieee.org> Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I573b0ce0316f997755f87b6f1ea5bdb3a6a29071
Diffstat (limited to 'gnu/packages')