From 5209b53e9689ce28dcd045f384633378d619718f Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Jan=20Wi=C5=9Bniewski?= Date: Thu, 5 Nov 2020 16:18:52 +0100 Subject: [PATCH] convert IFDRational to tuples in tests This fixes tests with Pillow version >= 7.2.0 --- tests/s_test.py | 12 ++++++++++++ 1 file changed, 12 insertions(+) diff --git a/tests/s_test.py b/tests/s_test.py index 5d105de..a7cad54 100644 --- a/tests/s_test.py +++ b/tests/s_test.py *************** *** 9,14 **** --- 9,15 ---- import time import unittest + import PIL from PIL import Image import piexif from piexif import _common, ImageIFD, ExifIFD, GPSIFD, TAGS, InvalidImageDataError *************** *** 580,585 **** --- 581,597 ---- # test utility methods---------------------------------------------- def _compare_value(self, v1, v2): + if isinstance(v2, PIL.TiffImagePlugin.IFDRational): + v2 = (v2.numerator, v2.denominator) + if isinstance(v2, tuple): + converted_v2 = [] + for el in v2: + if isinstance(el, PIL.TiffImagePlugin.IFDRational): + converted_v2.append((el.numerator, el.denominator)) + else: + converted_v2.append(el) + v2 = tuple(converted_v2) + if type(v1) != type(v2): if isinstance(v1, tuple): self.assertEqual(pack_byte(*v1), v2) 510b100a852147c7557d1f277f'>commitdiff
path: root/gnu/services/security-token.scm
AgeCommit message (Collapse)Author
2023-12-22services: Remove unnecessary references to (gnu build shepherd).Ludovic Courtès
* gnu/services/databases.scm (memcached-shepherd-service): Remove ‘with-imported-modules’ form and ‘modules’ field. * gnu/services/security-token.scm (pcscd-shepherd-service): Remove ‘with-imported-modules’ form. * gnu/services/web.scm (hpcguix-web-shepherd-service): Likewise. Change-Id: Ieb817508f1751e0c1ff551a0e078789a4a813c1c
2022-06-25services: pcscd: Use switch-symlinks from (guix build utils).Arun Isaac
switch-symlinks has been moved to (guix build utils). We need not duplicate it anymore. * gnu/services/security-token.scm (pcscd-activation): Use switch-symlinks from (guix build utils).
2021-07-03services: pcscd: Fix daemon signal handling.Brice Waegeneire
"pcscd" wouldn't handle SIGTERM as it inherit ignoring this signal (and others) from its parent shepherd; fork+exec-command restore signal handling. Fixes <https://issues.guix.gnu.org/45202>. * gnu/services/security-token.scm (pcscd)[start]: Use fork+exec-command to start "pcscd".
2021-06-19services: pcscd: Cleanup socket when started.Brice Waegeneire
Otherwise when pcscd doesn't terminate properly (ie. receive a SIGKILL), it won't start again because of it's socket already existing. * gnu/services/security-token.scm (pcscd-shepherd-service)[start]: Remove existing socket file.