Taken from upstream: https://github.com/pdoc3/pdoc/commit/4aa70de2221a34a3003a7e5f52a9b91965f0e359.patch. From 4aa70de2221a34a3003a7e5f52a9b91965f0e359 Mon Sep 17 00:00:00 2001 From: Spencer Baugh Date: Thu, 23 Sep 2021 09:00:25 -0400 Subject: [PATCH] TST: use explicit ClassWithNew instead of typing.Generic typing.Generic doesn't have a __new__ method in 3.9. Fixes https://github.com/pdoc3/pdoc/issues/355 --- pdoc/test/__init__.py | 10 +++++++--- 1 file changed, 7 insertions(+), 3 deletions(-) diff --git a/pdoc/test/__init__.py b/pdoc/test/__init__.py index e8c3d94..8b67ab7 100644 --- a/pdoc/test/__init__.py +++ b/pdoc/test/__init__.py @@ -1043,16 +1043,20 @@ class C2: self.assertEqual(pdoc.Class('C2', mod, C2).params(), ['a', 'b', 'c=None', '*', 'd=1', 'e']) - class G(typing.Generic[T]): + class ClassWithNew: + def __new__(self, arg): + pass + + class G(ClassWithNew): def __init__(self, a, b, c=100): pass self.assertEqual(pdoc.Class('G', mod, G).params(), ['a', 'b', 'c=100']) - class G2(typing.Generic[T]): + class G2(ClassWithNew): pass - self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['*args', '**kwds']) + self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['arg']) def test_url(self): mod = pdoc.Module(EXAMPLE_MODULE) 7c2738'>diff
path: root/gnu/ci.scm
AgeCommit message (Expand)Author
2024-07-10gnu: ci: Cross-build for fewer platforms....Efraim Flashner
2024-06-13ci: Add cross-compilation jobs for x86_64-linux-gnux32....Ludovic Courtès
2024-05-31ci: Build visionfive2-barebones-raw-image....Zheng Junjie
2024-04-17ci: Don’t cross-compile to xtensa-ath9k-elf....Ludovic Courtès
2024-01-23ci: Don't cross compile to or1k-elf....Mathieu Othacehe
2023-12-18gnu: ci: Build tuned packages for common baselines....Efraim Flashner
2023-12-12ci: Don't cross compile to avr....Efraim Flashner
2023-09-20image: Introduce the mbr-hybrid-raw image type....Mathieu Othacehe
2023-08-21ci: Really honor system type for manifests....Ludovic Courtès
2023-08-21ci: Honor user-specific systems for manifests....Ludovic Courtès
2023-08-18gnu: commencement: Use system in %final-inputs....Christopher Baines
2023-04-18ci: Add 'gdb-minimal' to the "core" package set....Ludovic Courtès
2023-03-09ci: Update the list of GCC versions for the 'core' subset....Ludovic Courtès