Remove this test to verify that things were modified since a certain time.
That assumption doesn't hold up when your environment doesn't have access to a
real clock and thinks it's living in 1970 :)
--- a/tests/test_fileapp.py 2015-04-23 13:48:37.000000000 -0700
+++ b/tests/test_fileapp.py 2016-02-22 19:20:08.332802417 -0800
@@ -223,8 +223,6 @@
status=304)
res = app.get('/', headers={'If-None-Match': 'asdf'},
status=200)
- res = app.get('/', headers={'If-Modified-Since': 'Sat, 1 Jan 2005 12:00:00 GMT'},
- status=200)
res = app.get('/', headers={'If-Modified-Since': last_mod + '; length=100'},
status=304)
res = app.get('/', headers={'If-Modified-Since': 'invalid date'},
pts'>koszko-scripts
gnu: guix: Remove unnecessary dependencies....This reverts 0fda0486523d67c2c464386c07a0c2800d8d8c20, instead moving
the dependencies needed for ‘make dist’ to ‘manifest.scm’.
Removing this extra dependencies make it simpler to build the ‘guix’
package in particular on less-capable systems like i586-gnu.
* gnu/packages/package-management.scm (guix)[native-inputs]: Remove
IMAGEMAGICK and PERL. Use GRAPHVIZ-MINIMAL instead of GRAPHVIZ.
* manifest.scm: Use the full-blown ‘graphviz’ package; add ‘imagemagick’
and ‘perl’.
Reported-by: Janneke Nieuwenhuizen <janneke@gnu.org>
Change-Id: Ia9d05c699e3cc2f9a9235a67f8ec840c26b66a82
Ludovic Courtès
2024-06-24
manifest: Streamline; add packages useful for patch review/submission....* manifest.scm: Fix alternate command line invocation (which would not
consider 'manifest.scm'). Use specifications instead of packages. Remove
perl (now in the guix package's native inputs). Add b4, git, git:send-email,
mumi, nss-certs, openssl and patman to the manifest.
Change-Id: I49d92dda059856ce217cea9054a466a1754dcf94
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>