Fix regex so that it works with Python 3.6. See . Copied from upstream bug report: https://bugs.launchpad.net/python-mox3/+bug/1665266 From 05064cdb6ea7a16450c6beae2b6f7c6074212a69 Mon Sep 17 00:00:00 2001 From: Zac Medico Date: Thu, 16 Feb 2017 00:24:10 -0800 Subject: [PATCH] RegexTest: python3.6 compatibility These fixes are backward-compatible with older python versions: * raw strings fix invalid escape sequences * flags=8 fixes ValueError: cannot use LOCALE flag with a str pattern --- mox3/tests/test_mox.py | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/mox3/tests/test_mox.py b/mox3/tests/test_mox.py index 15ac565..3a1af17 100644 --- a/mox3/tests/test_mox.py +++ b/mox3/tests/test_mox.py @@ -312,12 +312,12 @@ class RegexTest(testtools.TestCase): def testReprWithoutFlags(self): """repr should return the regular expression pattern.""" self.assertTrue( - repr(mox.Regex(r"a\s+b")) == "") + repr(mox.Regex(r"a\s+b")) == r"") def testReprWithFlags(self): """repr should return the regular expression pattern and flags.""" - self.assertTrue(repr(mox.Regex(r"a\s+b", flags=4)) == - "") + self.assertTrue(repr(mox.Regex(r"a\s+b", flags=8)) == + r"") class IsTest(testtools.TestCase): -- 2.10.2 nu/packages/acl.scm'>
AgeCommit message (Expand)Author
2018-03-16gnu: acl: Use invoke instead of system*....Mark H Weaver
2018-03-15gnu: acl: Fix build failure....Ricardo Wurmus
2018-02-16Merge branch 'master' into core-updatesMark H Weaver
2018-02-16gnu: Use HTTPS for supported nongnu.org home pages....Tobias Geerinckx-Rice
2017-11-09gnu: acl: Fix test regression with perl-5.26....Efraim Flashner
2017-11-04gnu: acl: Fix typo....Leo Famulari
2017-11-04gnu: acl: Enable tests....Kei Kebreau
2017-10-19gnu: acl: Use 'modify-phases' syntax....Efraim Flashner
2016-09-28gnu: Add and use gettext-minimal....Alex Kost