This patch fixes a crash in the libxml2 bindings for Python 3.x that 'itstool' stumbles upon when processing UTF-8 data: https://issues.guix.gnu.org/issue/37468 Patch by Jan Matejek from . --- libxml2-2.9.5.orig/python/libxml.c +++ libxml2-2.9.5/python/libxml.c @@ -1620,6 +1620,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU PyObject *message; PyObject *result; char str[1000]; + unsigned char *ptr = (unsigned char *)str; #ifdef DEBUG_ERROR printf("libxml_xmlErrorFuncHandler(%p, %s, ...) called\n", ctx, msg); @@ -1636,12 +1637,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU str[999] = 0; va_end(ap); +#if PY_MAJOR_VERSION >= 3 + /* Ensure the error string doesn't start at UTF8 continuation. */ + while (*ptr && (*ptr & 0xc0) == 0x80) + ptr++; +#endif + list = PyTuple_New(2); PyTuple_SetItem(list, 0, libxml_xmlPythonErrorFuncCtxt); Py_XINCREF(libxml_xmlPythonErrorFuncCtxt); - message = libxml_charPtrConstWrap(str); + message = libxml_charPtrConstWrap(ptr); PyTuple_SetItem(list, 1, message); result = PyEval_CallObject(libxml_xmlPythonErrorFuncHandler, list); + /* Forget any errors caused in the error handler. */ + PyErr_Clear(); Py_XDECREF(list); Py_XDECREF(result); } e83ec83eca8d555913e59235902fa635b052d'>diff
path: root/.gitignore
AgeCommit message (Expand)Author
2020-03-30.gitignore: Ignore test results in tests/services....Marius Bakke
2020-03-11Add system start-up files for guix-daemon....Danny Milosavljevic
2019-09-24Merge branch 'master' into core-updatesLudovic Courtès
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-06-14build: Remove 'gnu/packages/bootstrap' and its binaries....Ludovic Courtès
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès