This patch fixes a crash in the libxml2 bindings for Python 3.x that 'itstool' stumbles upon when processing UTF-8 data: https://issues.guix.gnu.org/issue/37468 Patch by Jan Matejek from . --- libxml2-2.9.5.orig/python/libxml.c +++ libxml2-2.9.5/python/libxml.c @@ -1620,6 +1620,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU PyObject *message; PyObject *result; char str[1000]; + unsigned char *ptr = (unsigned char *)str; #ifdef DEBUG_ERROR printf("libxml_xmlErrorFuncHandler(%p, %s, ...) called\n", ctx, msg); @@ -1636,12 +1637,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU str[999] = 0; va_end(ap); +#if PY_MAJOR_VERSION >= 3 + /* Ensure the error string doesn't start at UTF8 continuation. */ + while (*ptr && (*ptr & 0xc0) == 0x80) + ptr++; +#endif + list = PyTuple_New(2); PyTuple_SetItem(list, 0, libxml_xmlPythonErrorFuncCtxt); Py_XINCREF(libxml_xmlPythonErrorFuncCtxt); - message = libxml_charPtrConstWrap(str); + message = libxml_charPtrConstWrap(ptr); PyTuple_SetItem(list, 1, message); result = PyEval_CallObject(libxml_xmlPythonErrorFuncHandler, list); + /* Forget any errors caused in the error handler. */ + PyErr_Clear(); Py_XDECREF(list); Py_XDECREF(result); } store?id=88bcee3235d044262621e874ee0c4324b44de5cb'>diff
path: root/nix/libstore
AgeCommit message (Expand)Author
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès
2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès
2022-09-11daemon: Remove unused function findOutput....Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice