This patch fixes a crash in the libxml2 bindings for Python 3.x that 'itstool' stumbles upon when processing UTF-8 data: https://issues.guix.gnu.org/issue/37468 Patch by Jan Matejek from . --- libxml2-2.9.5.orig/python/libxml.c +++ libxml2-2.9.5/python/libxml.c @@ -1620,6 +1620,7 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU PyObject *message; PyObject *result; char str[1000]; + unsigned char *ptr = (unsigned char *)str; #ifdef DEBUG_ERROR printf("libxml_xmlErrorFuncHandler(%p, %s, ...) called\n", ctx, msg); @@ -1636,12 +1637,20 @@ libxml_xmlErrorFuncHandler(ATTRIBUTE_UNU str[999] = 0; va_end(ap); +#if PY_MAJOR_VERSION >= 3 + /* Ensure the error string doesn't start at UTF8 continuation. */ + while (*ptr && (*ptr & 0xc0) == 0x80) + ptr++; +#endif + list = PyTuple_New(2); PyTuple_SetItem(list, 0, libxml_xmlPythonErrorFuncCtxt); Py_XINCREF(libxml_xmlPythonErrorFuncCtxt); - message = libxml_charPtrConstWrap(str); + message = libxml_charPtrConstWrap(ptr); PyTuple_SetItem(list, 1, message); result = PyEval_CallObject(libxml_xmlPythonErrorFuncHandler, list); + /* Forget any errors caused in the error handler. */ + PyErr_Clear(); Py_XDECREF(list); Py_XDECREF(result); } ructures.scm?id=27c2917ac4e18ec0e1e9bb369d3e5e71ec4b5b61'>commitdiff
path: root/gnu/packages/datastructures.scm
AgeCommit message (Expand)Author
2019-01-26gnu: uthash: Use INVOKE....Ricardo Wurmus
2019-01-26gnu: uthash: Fetch sources via git....Ricardo Wurmus
2019-01-19gnu: liburcu: Update to 0.10.2....Tobias Geerinckx-Rice
2019-01-19gnu: liburcu: Use HTTPS home page....Tobias Geerinckx-Rice
2019-01-07gnu: Add sdsl-lite....Ricardo Wurmus
2018-11-10gnu: Add marisa....Meiyo Peng
2018-01-24gnu: liburcu: Update to 0.10.1....Tobias Geerinckx-Rice
2017-12-12gnu: Add uthash....Tobias Geerinckx-Rice