Fix handling of uint32_t arguments on the MIPS N32 ABI. Patch by Mark H Weaver . --- Modules/_ctypes/libffi/src/mips/ffi.c.orig 2013-03-16 07:19:39.000000000 -0400 +++ Modules/_ctypes/libffi/src/mips/ffi.c 2013-10-22 01:11:03.111985247 -0400 @@ -170,7 +170,14 @@ break; case FFI_TYPE_UINT32: +#ifdef FFI_MIPS_N32 + /* The N32 ABI requires that 32-bit integers + be sign-extended to 64-bits, regardless of + whether they are signed or unsigned. */ + *(ffi_arg *)argp = *(SINT32 *)(* p_argv); +#else *(ffi_arg *)argp = *(UINT32 *)(* p_argv); +#endif break; /* This can only happen with 64bit slots. */ 303b86473f'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
AgeCommit message (Expand)Author
2022-06-20gnu: drbd-utils: Generate manual pages.Marius Bakke
2022-06-20gnu: drbd-utils: Use new style.Marius Bakke
2022-06-20gnu: drbd-utils: Update to 9.21.2.Marius Bakke
2022-06-20gnu: drbd-utils: Add release-monitoring-url.Marius Bakke
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-12-05gnu: drbd-utils: Update to 9.19.1.Marius Bakke
2021-10-11gnu: drbd-utils: Update to 9.19.0.Marius Bakke
2021-09-28gnu: libdqlite: Update to 1.9.0.Andrew Whatson
2021-09-28gnu: libraft: Update to 0.11.2.Andrew Whatson
2021-06-05gnu: Add libdqlite.Dion Mendel
2021-05-28gnu: libraft: Update to 0.10.1Dion Mendel
2020-11-30gnu: drbd-utils: Update to 9.15.1.Tobias Geerinckx-Rice
2020-10-10gnu: drbd-utils: Update to 9.15.0.Marius Bakke
2020-07-02gnu: Add drbd-utils.Marius Bakke
2020-01-08gnu: keepalived: Update to 2.0.19.Oleg Pykhalov
2019-12-11gnu: libraft: Update to 0.9.11.Andrew Miloradovsky