From cef2c8df44166195e1705638f9f17033a4943bb7 Mon Sep 17 00:00:00 2001 From: Simon Cross Date: Sun, 16 Feb 2014 18:32:21 +0000 Subject: [PATCH 02/15] Disable the speedups C extension on CPython >= 3.3 since Genshi doesn't support the new Unicode C API yet. --- setup.py | 6 +++++- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/setup.py b/setup.py index 123a2cb..a3d748c 100755 --- a/setup.py +++ b/setup.py @@ -65,9 +65,13 @@ available.""") if Feature: + # Optional C extension module for speeding up Genshi: + # Not activated by default on: + # - PyPy (where it harms performance) + # - CPython >= 3.3 (the new Unicode C API is not supported yet) speedups = Feature( "optional C speed-enhancements", - standard = not is_pypy, + standard = not is_pypy and sys.version_info < (3, 3), ext_modules = [ Extension('genshi._speedups', ['genshi/_speedups.c']), ], -- 2.12.0 '/guix/about/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
AgeCommit message (Expand)Author
2018-03-16gnu: acl: Use invoke instead of system*....Mark H Weaver
2018-03-15gnu: acl: Fix build failure....Ricardo Wurmus
2018-02-16Merge branch 'master' into core-updatesMark H Weaver
2018-02-16gnu: Use HTTPS for supported nongnu.org home pages....Tobias Geerinckx-Rice
2017-11-09gnu: acl: Fix test regression with perl-5.26....Efraim Flashner
2017-11-04gnu: acl: Fix typo....Leo Famulari
2017-11-04gnu: acl: Enable tests....Kei Kebreau
2017-10-19gnu: acl: Use 'modify-phases' syntax....Efraim Flashner