We need one patch on top of 0.3.8 for compatibility with Werkzeug 1.0. Taken from upstream: https://github.com/flask-restful/flask-restful/commit/73376a488907af3042b52678ac4c23f8a8911e5b diff --git a/tests/test_api.py b/tests/test_api.py index f7f8e661..6795d362 100644 --- a/tests/test_api.py +++ b/tests/test_api.py @@ -445,7 +445,9 @@ def test_handle_non_api_error(self): resp = app.get("/foo") self.assertEquals(resp.status_code, 404) - self.assertEquals('text/html', resp.headers['Content-Type']) + # in newer versions of werkzeug this is `text/html; charset=utf8` + content_type, _, _ = resp.headers['Content-Type'].partition(';') + self.assertEquals('text/html', content_type) def test_non_api_error_404_catchall(self): app = Flask(__name__) diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py index 2f1fbedf..9776f17c 100644 --- a/tests/test_reqparse.py +++ b/tests/test_reqparse.py @@ -2,9 +2,9 @@ import unittest from mock import Mock, patch from flask import Flask -from werkzeug import exceptions, MultiDict +from werkzeug import exceptions from werkzeug.wrappers import Request -from werkzeug.datastructures import FileStorage +from werkzeug.datastructures import FileStorage, MultiDict from flask_restful.reqparse import Argument, RequestParser, Namespace import six import decimal uix/diff/po/packages/fr.po?id=c93c7af1cef08ae0a0aeccf3e3c0af188abddc81'>diff
path: root/po/packages/fr.po
AgeCommit message (Expand)Author
2021-12-04nls: Update translations.Julien Lepiller
2021-11-06nls: Update translations....* po/doc/guix-cookbook.es.po: New file. * po/doc/local.mk: Add 'es' cookbook. * doc/local.mk: Add 'es' cookbook. Julien Lepiller
2021-10-17nls: Update translations.Julien Lepiller
2021-09-02nls: Update translations....* po/packages/it.po: New file. * po/packages/LINGUAS: Add `it'. * po/*/*.po: Update translations. Julien Lepiller
2021-08-04nls: Update translations....* po/doc/guix-cookbook.ru.po: New file. * po/doc/guix-cookbook.sk.po: New file. * po/*/*.po: Update translations. * doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk. (info_TEXINFOS): Add Russian and Slovak cookbooks. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po files. Julien Lepiller
2021-05-10nls: Update translations.Maxim Cournoyer
2021-04-18nls: Update 'fr' translations.Julien Lepiller
2021-01-28nls: Update 'fr' translation.Julien Lepiller
2020-11-09nls: Update 'fr' translations.Julien Lepiller
2020-10-27nls: Update.Ludovic Courtès
2020-10-16nls: Update.Ludovic Courtès
2020-04-14nls: Update.Ludovic Courtès