Since feedparser messes with Python’s internals by assigning to __code__ it needs to import SGMLParseError too. It also expects SGMLParseError, which was turned into AssertionError by https://github.com/python/cpython/commit/e34bbfd61f405eef89e8aa50672b0b25022de320 --- feedparser-6.0.10/feedparser/sgml.py.orig 2023-03-18 09:24:50.976316932 +0100 +++ feedparser-6.0.10/feedparser/sgml.py 2023-03-18 09:26:32.971928811 +0100 @@ -28,6 +28,7 @@ import re import sgmllib +from sgmllib import SGMLParseError __all__ = [ 'sgmllib', @@ -41,6 +42,7 @@ 'shorttagopen', 'starttagopen', 'endbracket', + 'SGMLParseError', ] # sgmllib defines a number of module-level regular expressions that are --- feedparser-6.0.10/feedparser/html.py.orig 2023-03-18 09:32:03.647114745 +0100 +++ feedparser-6.0.10/feedparser/html.py 2023-03-18 09:46:05.021142671 +0100 @@ -349,7 +349,7 @@ try: return sgmllib.SGMLParser.parse_declaration(self, i) - except sgmllib.SGMLParseError: + except AssertionError: # Escape the doctype declaration and continue parsing. self.handle_data('<') return i+1 e'>refslogtreecommitdiff
path: root/gnu/packages/mingw.scm
AgeCommit message (Collapse)Author
2018-08-09gnu: mingw-w64: Update to 5.0.4.Tobias Geerinckx-Rice
* gnu/packages/mingw.scm (mingw-w64): Update to 5.0.4.
2018-03-12gnu: mingw-w64: Update to 5.0.3.Tobias Geerinckx-Rice
* gnu/packages/mingw.scm (mingw-w64): Update to 5.0.3.
2018-03-12gnu: mingw-w64: Fix home page and avoid further confusion.Tobias Geerinckx-Rice
MinGW-w64 was forked (in rather dramatic fashion) from the original MinGW. The two projects remain distinct and MinGW-w64 seems by far the actively developed of the two. * gnu/packages/mingw.scm (mingw-w64)[home-page]: Point to the correct upstream. Use HTTPS. [description]: Expand and briefly note the relationship between the two projects. Use @dfn.
2017-11-08gnu: Remove "open source" from descriptions.Ricardo Wurmus
All software in Guix is Free Software. * gnu/packages/aidc.scm (libdmtx)[description]: Remove "open source" string. * gnu/packages/firmware.scm (seabios)[description]: Likewise. * gnu/packages/libupnp.scm (libupnp)[description]: Likewise. * gnu/packages/maths.scm (cubicle)[description]: Likewise. * gnu/packages/mingw.scm (mingw-w64)[description]: Likewise. * gnu/packages/game-development.scm (openmw)[description]: Likewise. [synopsis]: Remove "Free software".