Since feedparser messes with Python’s internals by assigning
to __code__ it needs to import SGMLParseError too. It also
expects SGMLParseError, which was turned into AssertionError by
https://github.com/python/cpython/commit/e34bbfd61f405eef89e8aa50672b0b25022de320
--- feedparser-6.0.10/feedparser/sgml.py.orig 2023-03-18 09:24:50.976316932 +0100
+++ feedparser-6.0.10/feedparser/sgml.py 2023-03-18 09:26:32.971928811 +0100
@@ -28,6 +28,7 @@
import re
import sgmllib
+from sgmllib import SGMLParseError
__all__ = [
'sgmllib',
@@ -41,6 +42,7 @@
'shorttagopen',
'starttagopen',
'endbracket',
+ 'SGMLParseError',
]
# sgmllib defines a number of module-level regular expressions that are
--- feedparser-6.0.10/feedparser/html.py.orig 2023-03-18 09:32:03.647114745 +0100
+++ feedparser-6.0.10/feedparser/html.py 2023-03-18 09:46:05.021142671 +0100
@@ -349,7 +349,7 @@
try:
return sgmllib.SGMLParser.parse_declaration(self, i)
- except sgmllib.SGMLParseError:
+ except AssertionError:
# Escape the doctype declaration and continue parsing.
self.handle_data('<')
return i+1
mux.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-10-05 | gnu: tmux: Update to 3.5a....* gnu/packages/tmux.scm (tmux): Update to 3.5a.
Change-Id: I1e92cfcdb374f5a0131354900289766cbdf431e7
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
| Ashish SHUKLA via Guix-patches via |
2024-09-27 | gnu: tmux: Build from git....* gnu/packages/tmux.scm (tmux)[source]: Switch to git-fetch, and use
git-file-name.
[native-inputs]: Add autoconf, automake and pkg-config.
Change-Id: If56abbb76f3b00193bbd27c236a9f82c4f0eb3cb
| Zheng Junjie |
2024-09-27 | gnu: tmux: Update to 3.5....* gnu/packages/tmux (tmux): Update to 3.5.
Change-Id: Ia1f4e6e6d17d8ce76345f06f87247a13b4b5a7bb
Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
| Ashish SHUKLA via Guix-patches via |
2024-05-12 | gnu: tmux: Update to 3.4....* gnu/packages/tmux.scm (tmux): Update to 3.4.
[native-inputs]: Add bison.
Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
Signed-off-by: Christopher Baines <mail@cbaines.net>
Change-Id: I549010a3cf492ffe9cdc9df25b2b4a93c60c6ae1
| Ashish SHUKLA |