Since feedparser messes with Python’s internals by assigning to __code__ it needs to import SGMLParseError too. It also expects SGMLParseError, which was turned into AssertionError by https://github.com/python/cpython/commit/e34bbfd61f405eef89e8aa50672b0b25022de320 --- feedparser-6.0.10/feedparser/sgml.py.orig 2023-03-18 09:24:50.976316932 +0100 +++ feedparser-6.0.10/feedparser/sgml.py 2023-03-18 09:26:32.971928811 +0100 @@ -28,6 +28,7 @@ import re import sgmllib +from sgmllib import SGMLParseError __all__ = [ 'sgmllib', @@ -41,6 +42,7 @@ 'shorttagopen', 'starttagopen', 'endbracket', + 'SGMLParseError', ] # sgmllib defines a number of module-level regular expressions that are --- feedparser-6.0.10/feedparser/html.py.orig 2023-03-18 09:32:03.647114745 +0100 +++ feedparser-6.0.10/feedparser/html.py 2023-03-18 09:46:05.021142671 +0100 @@ -349,7 +349,7 @@ try: return sgmllib.SGMLParser.parse_declaration(self, i) - except sgmllib.SGMLParseError: + except AssertionError: # Escape the doctype declaration and continue parsing. self.handle_data('<') return i+1 diff/gnu/packages'>diff
path: root/gnu/packages
>root/etc/release-manifest.scm
AgeCommit message (Collapse)Author
AgeCommit message (Expand)Author
2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....Josselin Poiret
2022-05-22ci: Do not rely on hardcoded cross-targets lists....Mathieu Othacehe
2021-12-08maint: Don't require unsupported packages such as GNOME on i686-linux....Ludovic Courtès
2021-04-27maint: Require "emacs-no-x" instead of "emacs" on armhf-linux....Ludovic Courtès
2021-04-27maint: Don't require 'bootstrap-tarballs' for powerpc64le-linux....Ludovic Courtès
2021-03-10ci: Remove hydra support....Mathieu Othacehe
2020-11-08maint: Reduce the package set for "i586-gnu"....Ludovic Courtès
2020-10-13installer: Add Emacs EXWM desktop environment....Jan (janneke) Nieuwenhuizen
2020-04-15Merge branch 'master' into core-updatesMarius Bakke
2020-04-14maint: Ensure substitutes are available for '%default-xorg-modules'....Ludovic Courtès
2020-04-14maint: Actually check for the availablility of system packages....Ludovic Courtès
2020-04-08maint: Adjust release manifest for Guile 3.0 switch....Marius Bakke
2020-04-08maint: Cross-build GUILE-2.2/FIXED....Ludovic Courtès
2020-04-07maint: Remove GCC from the packages to cross-build....Ludovic Courtès
2020-04-04maint: Remove unsupported cross-compilation jobs from 'release-manifest.scm'....Ludovic Courtès