Add compatibility with newer versions of pytest. Taken from upstream: https://github.com/dateutil/dateutil/commit/2bdd63158b7f981fc6d70a869680451bdfd8d848 diff --git a/dateutil/test/test_internals.py b/dateutil/test/test_internals.py index 53081314..b32e6723 100644 --- a/dateutil/test/test_internals.py +++ b/dateutil/test/test_internals.py @@ -9,6 +9,7 @@ import sys import pytest +import warnings from dateutil.parser._parser import _ymd from dateutil import tz @@ -65,18 +66,17 @@ def test_parser_parser_private_not_warns(): from dateutil.parser._parser import _timelex, _tzparser from dateutil.parser._parser import _parsetz - with pytest.warns(None) as recorder: + with warnings.catch_warnings(): + warnings.simplefilter("error") _tzparser() - assert len(recorder) == 0 - with pytest.warns(None) as recorder: + with warnings.catch_warnings(): + warnings.simplefilter("error") _timelex('2014-03-03') - assert len(recorder) == 0 - - with pytest.warns(None) as recorder: + with warnings.catch_warnings(): + warnings.simplefilter("error") _parsetz('+05:00') - assert len(recorder) == 0 @pytest.mark.tzstr .scm?id=56586f9b9eeb3c6d0b96522bd7658a643669ef0c'>treecommitdiff
path: root/gnu/tests/web.scm
AgeCommit message (Expand)Author
2023-01-22gnu: hpcguix-web: Update to 0.3.0....Ludovic Courtès
2022-05-01tests: Fix tailon test....Mathieu Othacehe
2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe
2021-12-06tests: patchwork: Use the default PostgreSQL....Marius Bakke
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-15gnu: hpcguix-web: Update to 0.2.0....Ludovic Courtès
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès