Ensure that no feature set refers to blas-src or lapack-src, because we want
to just use the existing openblas library.
--- a/Cargo.toml 2024-04-24 14:13:23.519997967 +0200
+++ b/Cargo.toml 2024-04-24 14:13:09.983966101 +0200
@@ -34,11 +34,11 @@
sdp = ["blas","lapack"]
# explicit configuration options for different blas flavours
-sdp-accelerate = ["sdp", "blas-src/accelerate", "lapack-src/accelerate"]
-sdp-netlib = ["sdp", "blas-src/netlib", "lapack-src/netlib"]
-sdp-openblas = ["sdp", "blas-src/openblas", "lapack-src/openblas"]
-sdp-mkl = ["sdp", "blas-src/intel-mkl", "lapack-src/intel-mkl"]
-sdp-r = ["sdp", "blas-src/r", "lapack-src/r"]
+sdp-accelerate = ["sdp"]
+sdp-netlib = ["sdp"]
+sdp-openblas = ["sdp"]
+sdp-mkl = ["sdp"]
+sdp-r = ["sdp"]
# build as the julia interface
julia = ["sdp", "dep:libc", "dep:num-derive", "dep:serde", "dep:serde_json"]
@@ -62,15 +62,6 @@
version = "0.19.0"
optional = true
-[dependencies.blas-src]
-version = "0.9"
-optional = true
-
-[dependencies.lapack-src]
-version = "0.9"
-optional = true
-
-
# -------------------------------
# examples
# -------------------------------
'/guix/log/tests/file-systems.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2020-05-20 | bootloader: grub: Allow booting from a Btrfs subvolume....* gnu/bootloader/grub.scm (strip-mount-point): Remove procedure.
(normalize-file): Add procedure.
(grub-configuration-file): New BTRFS-SUBVOLUME-FILE-NAME parameter. When
defined, prepend its value to the kernel and initrd file names, using the
NORMALIZE-FILE procedure. Adjust the call to EYE-CANDY to pass the
BTRFS-SUBVOLUME-FILE-NAME argument. Normalize the KEYMAP file as well.
(eye-candy): Add a BTRFS-SUBVOLUME-FILE-NAME parameter, and use it, along with
the NORMALIZE-FILE procedure, to normalize the FONT-FILE and IMAGE nested
variables. Adjust doc.
* gnu/bootloader/depthcharge.scm (depthcharge-configuration-file): Adapt.
* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Likewise.
* gnu/system/file-systems.scm (btrfs-subvolume?)
(btrfs-store-subvolume-file-name): New procedures.
* gnu/system.scm (operating-system-bootcfg): Specify the Btrfs
subvolume file name the store resides on to the
`operating-system-bootcfg' procedure, using the new
BTRFS-SUBVOLUME-FILE-NAME argument.
* doc/guix.texi (File Systems): Add a Btrfs subsection to document the use of
subvolumes.
* gnu/tests/install.scm (%btrfs-root-on-subvolume-os)
(%btrfs-root-on-subvolume-os-source)
(%btrfs-root-on-subvolume-installation-script)
(%test-btrfs-root-on-subvolume-os): New variables.
| Maxim Cournoyer |
2020-05-20 | file-systems: Add helpers for parsing the options string into an alist....* gnu/system/file-systems.scm (file-system-options->alist)
(alist->file-system-options): New procedures.
* tests/file-systems.scm: New tests.
* doc/guix.texi (File Systems): Add note about the newly added procedures.
| Maxim Cournoyer |