Ensure that no feature set refers to blas-src or lapack-src, because we want
to just use the existing openblas library.
--- a/Cargo.toml 2024-04-24 14:13:23.519997967 +0200
+++ b/Cargo.toml 2024-04-24 14:13:09.983966101 +0200
@@ -34,11 +34,11 @@
sdp = ["blas","lapack"]
# explicit configuration options for different blas flavours
-sdp-accelerate = ["sdp", "blas-src/accelerate", "lapack-src/accelerate"]
-sdp-netlib = ["sdp", "blas-src/netlib", "lapack-src/netlib"]
-sdp-openblas = ["sdp", "blas-src/openblas", "lapack-src/openblas"]
-sdp-mkl = ["sdp", "blas-src/intel-mkl", "lapack-src/intel-mkl"]
-sdp-r = ["sdp", "blas-src/r", "lapack-src/r"]
+sdp-accelerate = ["sdp"]
+sdp-netlib = ["sdp"]
+sdp-openblas = ["sdp"]
+sdp-mkl = ["sdp"]
+sdp-r = ["sdp"]
# build as the julia interface
julia = ["sdp", "dep:libc", "dep:num-derive", "dep:serde", "dep:serde_json"]
@@ -62,15 +62,6 @@
version = "0.19.0"
optional = true
-[dependencies.blas-src]
-version = "0.9"
-optional = true
-
-[dependencies.lapack-src]
-version = "0.9"
-optional = true
-
-
# -------------------------------
# examples
# -------------------------------
guix/log/tests/guix-refresh.sh'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-08-15 | refresh: Add --target-version option....* guix/scripts/refresh.scm (%options): Register 'target-version' long version.
(update-specification->update-spec): Add a fallback-version argument.
(options->update-specs): Honor target-version option.
* tests/guix-refresh.sh: Test it.
* doc/guix.texi (Invoking guix refresh): Document it.
Reviewed-by: Ludovic Courtès <ludo@gnu.org>
| Maxim Cournoyer |
2023-05-31 | upstream: Honor package properties for ignored and extra inputs....* guix/upstream.scm (update-package-inputs)[filtered-inputs]
[regular-inputs, native-inputs, propagated-inputs]: New procedures.
Use them in 'update-field' calls.
* tests/guix-refresh.sh (GUIX_TEST_UPDATER_TARGETS): Add "libreoffice"
to the dependencies of "the-test-package". Add 'updater-ignored-inputs'
property to "the-test-package".
* doc/guix.texi (Invoking guix refresh): Document it.
| Ludovic Courtès |
2023-05-31 | upstream: 'update-package-source' edits input fields....Previously, 'guix refresh r-ggplot2 -u' and similar commands would print
of list of input changes that would have to be made manually. With this
change, 'guix refresh -u' takes care of updating input fields
automatically.
* guix/upstream.scm (update-package-inputs): New procedure.
(update-package-source): Call it when 'upstream-source-inputs' returns
true.
* guix/scripts/refresh.scm (update-package): Remove iteration over the
result of 'changed-inputs'.
* guix/import/test.scm (available-updates): Add support for input
lists.
* tests/guix-refresh.sh (GUIX_TEST_UPDATER_TARGETS): Add input list for
"the-test-package".
Make sure 'guix refresh -u' updates 'inputs' accordingly.
* doc/guix.texi (Invoking guix refresh): Mention it.
| Ludovic Courtès |
2023-04-21 | tests: Relax two tests that expected a non-zero error code....* tests/guix-package-aliases.sh: "guix upgrade foo bar" has always
returned zero; adjust accordingly.
* tests/guix-refresh.sh: "guix refresh -t test idutils" and similar
return zero; adjust accordingly.
| Ludovic Courtès |
2023-04-21 | tests: Fix checks for expected failures....Addresses <https://issues.guix.gnu.org/62406>.
With 'set -e', a return status inverted with '!' does not cause the shell to
exit immediately. Instead use '&& false' to indicate an expected failure.
* tests/guix-archive.sh, tests/guix-build-branch.sh, tests/guix-build.sh,
tests/guix-daemon.sh, tests/guix-download.sh,
tests/guix-environment-container.sh, tests/guix-environment.sh,
tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh,
tests/guix-hash.sh, tests/guix-home.sh, tests/guix-pack-relocatable.sh,
tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh,
tests/guix-package.sh, tests/guix-refresh.sh, tests/guix-shell.sh,
tests/guix-style.sh, tests/guix-system.sh: Replace uses of '! ...' with
'... && false' or `test ! ...` as appropriate.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Eric Bavier |
2023-01-25 | tests: Do not try to create "$HOME/.config"....Previously this test would fail when HOME=/homeless-shelter and said
directory cannot be created.
* tests/guix-refresh.sh: Pass '--keyring' together with '-u'.
| Ludovic Courtès |
2023-01-08 | refresh: Add CLI tests....* guix/import/test.scm, tests/guix-refresh.sh: New files.
* Makefile.am (MODULES, SH_TESTS): Add them.
| Ludovic Courtès |