Patch copied from Gentoo removing obsolete Python2 code.
--- a/chai/chai.py
+++ b/chai/chai.py
@@ -62,11 +62,6 @@
try:
func(self, *args, **kwargs)
except UnexpectedCall as e:
- # if this is not python3, use python2 syntax
- if not hasattr(e, '__traceback__'):
- from .python2 import reraise
- reraise(
- AssertionError, '\n\n' + str(e), sys.exc_info()[-1])
exc = AssertionError('\n\n' + str(e))
setattr(exc, '__traceback__', sys.exc_info()[-1])
raise exc
--- a/chai/python2.py
+++ b/chai/python2.py
@@ -1,3 +0,0 @@
-
-def reraise(exc, msg, traceback):
- raise exc, msg, traceback
--- a/chai.egg-info/SOURCES.txt
+++ b/chai.egg-info/SOURCES.txt
@@ -10,7 +10,6 @@
chai/exception.py
chai/expectation.py
chai/mock.py
-chai/python2.py
chai/spy.py
chai/stub.py
chai.egg-info/PKG-INFO
>
Age | Commit message (Expand) | Author |
2023-12-27 | gnu: Add torbrowser....* gnu/packages/tor.scm (torbrowser): New variable.
(torbrowser-assets): New variable.
* gnu/packages/browser-extensions.scm (noscript): New variable.
(noscript/icecat): New variable.
Co-authored-by: André Batista <nandre@riseup.net>
Change-Id: I73dc53905e4a028108bb34aae07e44256cf16c85
| Clément Lassieur |
2023-12-11 | gnu: libgpg-error: Do not assume that target is a triplet....Fixes a bug exposed with be5ec2ebb4bde4b4f702a30f08849dff05cceccd, which
introduces the “avr” target, which has no hyphen.
* gnu/packages/gnupg.scm (libgpg-error)[arguments]: In ‘cross-symlinks’
phase, adjust code to deal with TARGET lacking a hyphen.
Change-Id: I1aff6a94a7c92626f931c459d1dc0509f9bcfc00
| Ludovic Courtès |