Upstream commit fixing testcases for fish>=3.1, see
https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
diff --git a/test/test.py b/test/test.py
index e91352b..2c34806 100755
--- a/test/test.py
+++ b/test/test.py
@@ -28,6 +28,8 @@
BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
+FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
+FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
class TempDir(object):
@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
expected_failures = [
'test_parse_special_characters',
'test_comp_point',
- 'test_special_characters_double_quoted'
]
+ if FISH_VERSION_TUPLE < (3, 1):
+ expected_failures.extend([
+ 'test_special_characters_double_quoted'
+ ])
skipped = [
'test_single_quotes_in_single_quotes',
'>aboutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: enchant: Update to 2.6.9....* gnu/packages/enchant.scm (enchant): Update to 2.6.9.
Change-Id: I7d5f229b0308e7a09101df0b8af344e03f2bbdbb
| Nicolas Goaziou |
2024-08-31 | gnu: enchant: Add Nuspell support....* gnu/packages/enchant.scm (enchant)[inputs]: Add NUSPELL.
Change-Id: I60d70e6b6e4952722559848f715fc68dcf3e11f4
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Nicolas Goaziou |
2024-08-31 | gnu: enchant: Improve package style....* gnu/packages/enchant.scm (enchant)[arguments]: Use G-expressions.
[native-inputs]: Drop input labels.
[description]: Be more informative and less technical.
Change-Id: I908fbbfcdc9f21beb1d6e05eec2dbc154b429831
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Nicolas Goaziou |
2024-08-31 | gnu: enchant: Update to 2.6.8....* gnu/packages/enchant.scm (enchant): Update to 2.6.8.
[native-inputs]: Add GROFF.
Change-Id: I8c7d7e2b9124a55401c6623fd76eacc0878ad6e6
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Nicolas Goaziou |
2024-03-25 | gnu: nuspell: Add search path specification for DICPATH....* gnu/packages/enchant.scm (nuspell)[native-search-path]: Add DICPATH.
This change is required to let Nuspell detect Hunspell dictionaries.
Change-Id: I731752142afcae1fc2b91c01fb9dbe914d33244f
| Nicolas Goaziou |
2024-03-25 | gnu: nuspell: Remove unnecessary inputs....* gnu/packages/enchant.scm (nuspell)[native-inputs]: Remove GIT-MINIMAL and
PERL.
[inputs]: remove BOOST.
Change-Id: I1847e4c68a5c40c5ebae75a0bbe651384250d8a7
| Nicolas Goaziou |
2024-03-25 | gnu: nuspell: Update to 5.1.4....* gnu/packages/enchant.scm (nuspell): Update to 5.1.4.
[native-inputs]: Use CATCH2-3. Remove comment about RONN, which is no longer used.
Change-Id: I62fa0568dacde29bef5065b2ee23c060373727cf
| Nicolas Goaziou |