Compatibility with Python 3.8, see upstream issue
https://github.com/rbarrois/aionotify/pull/15
diff --git a/setup.py b/setup.py
index 21a554f..094de64 100755
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
setup_requires=[
],
tests_require=[
- 'asynctest',
+ 'asynctest; python_version<"3.8"',
],
classifiers=[
"Development Status :: 4 - Beta",
diff --git a/tests/test_usage.py b/tests/test_usage.py
index f156291..0476ff1 100644
--- a/tests/test_usage.py
+++ b/tests/test_usage.py
@@ -8,7 +8,11 @@ import os.path
import tempfile
import unittest
-import asynctest
+try:
+ testBase = unittest.IsolatedAsyncioTestCase
+except AttributeError:
+ import asynctest
+ testBase = asynctest.TestCase
import aionotify
@@ -25,11 +29,13 @@ if AIODEBUG:
TESTDIR = os.environ.get('AIOTESTDIR') or os.path.join(os.path.dirname(__file__), 'testevents')
-class AIONotifyTestCase(asynctest.TestCase):
+class AIONotifyTestCase(testBase):
forbid_get_event_loop = True
timeout = 3
def setUp(self):
+ if not getattr (self, 'loop', None):
+ self.loop = asyncio.get_event_loop()
if AIODEBUG:
self.loop.set_debug(True)
self.watcher = aionotify.Watcher()
>commitdiff
|
Age | Commit message (Expand) | Author |
2024-01-14 | bootloader: grub: Add support for loading an additional initrd....In order to be able to provide decryption keys for the LUKS device, they need
to be available in the initial ram disk. However they cannot be stored inside
the usual initrd, since it is stored in the store and being a
world-readable (as files in the store are) is not a desired property for a
initrd containing decryption keys. This commit adds an option to load
additional initrd during the boot, one that is not stored inside the store and
therefore can contain secrets.
Since only grub supports encrypted /boot, only grub is modified to use the
extra-initrd. There is no use case for the other bootloaders.
* doc/guix.texi (Bootloader Configuration): Describe the new extra-initrd
field.
* gnu/bootloader.scm (<bootloader-configuration>): Add extra-initrd field.
* gnu/bootloader/grub.scm (make-grub-configuration): Use the extra-initrd
field.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Change-Id: I995989bb623bb594ccdafbf4a1a6de941bd4189f
| Tomas Volf |
2023-12-22 | gnu: bootloader: Add orangepi-r1-plus-lts-rk3328 bootloader....* gnu/bootloader/u-boot.scm (install-orangepi-r1-plus-lts-rk3328-u-boot,
u-boot-orangepi-r1-plus-lts-rk3328-bootloader): New variables.
* gnu/packages/bootloaders.scm (u-boot-orangepi-r1-plus-lts-rk3328): New
variable.
Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
| Herman Rimm |