Compatibility with Python 3.8, see upstream issue
https://github.com/rbarrois/aionotify/pull/15
diff --git a/setup.py b/setup.py
index 21a554f..094de64 100755
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
setup_requires=[
],
tests_require=[
- 'asynctest',
+ 'asynctest; python_version<"3.8"',
],
classifiers=[
"Development Status :: 4 - Beta",
diff --git a/tests/test_usage.py b/tests/test_usage.py
index f156291..0476ff1 100644
--- a/tests/test_usage.py
+++ b/tests/test_usage.py
@@ -8,7 +8,11 @@ import os.path
import tempfile
import unittest
-import asynctest
+try:
+ testBase = unittest.IsolatedAsyncioTestCase
+except AttributeError:
+ import asynctest
+ testBase = asynctest.TestCase
import aionotify
@@ -25,11 +29,13 @@ if AIODEBUG:
TESTDIR = os.environ.get('AIOTESTDIR') or os.path.join(os.path.dirname(__file__), 'testevents')
-class AIONotifyTestCase(asynctest.TestCase):
+class AIONotifyTestCase(testBase):
forbid_get_event_loop = True
timeout = 3
def setUp(self):
+ if not getattr (self, 'loop', None):
+ self.loop = asyncio.get_event_loop()
if AIODEBUG:
self.loop.set_debug(True)
self.watcher = aionotify.Watcher()
href='/guix/commit/gnu/tests.scm?id=4621cd7b8db00fd8230c8c5e51929f926aaf3795'>commitdiff
|
Age | Commit message (Expand) | Author |
2021-08-29 | Migrate to the new 'targets' field of bootloader-configuration....The old 'target' field is deprecated; adjust the sources to use the new
'targets' one instead.
* doc/guix-cookbook.texi<target>: Replace by 'targets'.
* gnu/bootloader/grub.scm: Likewise.
* gnu/installer/parted.scm: Likewise.
* gnu/machine/digital-ocean.scm: Likewise.
* gnu/system/examples/asus-c201.tmpl: Likewise
* gnu/system/examples/bare-bones.tmpl: Likewise
* gnu/system/examples/bare-hurd.tmpl: Likewise
* gnu/system/examples/beaglebone-black.tmpl: Likewise
* gnu/system/examples/desktop.tmpl: Likewise
* gnu/system/examples/docker-image.tmpl: Likewise
* gnu/system/examples/lightweight-desktop.tmpl: Likewise
* gnu/system/examples/vm-image.tmpl: Likewise
* gnu/system/examples/yggdrasil.tmpl: Likewise
* gnu/system/hurd.scm: Likewise
* gnu/system/images/hurd.scm: Likewise
* gnu/system/images/novena.scm: Likewise
* gnu/system/images/pine64.scm: Likewise
* gnu/system/images/pinebook-pro.scm: Likewise
* gnu/system/images/rock64.scm: Likewise
* gnu/system/install.scm: Likewise
* gnu/system/vm.scm: Likewise
* gnu/tests.scm: Likewise
* gnu/tests/ganeti.scm: Likewise
* gnu/tests/install.scm: Likewise
* gnu/tests/nfs.scm: Likewise
* gnu/tests/telephony.scm: Likewise
* tests/boot-parameters.scm: Likewise
* tests/system.scm: Likewise
| Maxim Cournoyer |
2021-04-12 | tests: Support package extensions in the backdoor REPL....* gnu/tests.scm
(<marionette-configuration>): Add 'extensions' field.
(marionette-shepherd-service): Honour the field.
(with-import-modules-and-extensions): Define a combination
of 'with-import-modules' and 'with-extensions'.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Maxime Devos |
2021-02-19 | tests: Export %simple-os....* gnu/tests.scm (%simple-os): Export it.
| Mathieu Othacehe |
2020-07-25 | utils: Move <location> and '&error-location' to (guix diagnostics)....* guix/utils.scm (<location>, source-properties->location)
(location->source-properties, &error-location): Move to...
* guix/diagnostics.scm: ... here.
* gnu.scm: Adjust imports accordingly.
* gnu/machine.scm: Likewise.
* gnu/system.scm: Likewise.
* gnu/tests.scm: Likewise.
* guix/inferior.scm: Likewise.
* tests/channels.scm: Likewise.
* tests/packages.scm: Likewise.
| Ludovic Courtès |
2020-03-05 | tests: Add <system-test> gexp compiler....* gnu/tests.scm (compile-system-test): New gexp compiler.
| Ludovic Courtès |