Compatibility with Python 3.8, see upstream issue https://github.com/rbarrois/aionotify/pull/15 diff --git a/setup.py b/setup.py index 21a554f..094de64 100755 --- a/setup.py +++ b/setup.py @@ -40,7 +40,7 @@ setup( setup_requires=[ ], tests_require=[ - 'asynctest', + 'asynctest; python_version<"3.8"', ], classifiers=[ "Development Status :: 4 - Beta", diff --git a/tests/test_usage.py b/tests/test_usage.py index f156291..0476ff1 100644 --- a/tests/test_usage.py +++ b/tests/test_usage.py @@ -8,7 +8,11 @@ import os.path import tempfile import unittest -import asynctest +try: + testBase = unittest.IsolatedAsyncioTestCase +except AttributeError: + import asynctest + testBase = asynctest.TestCase import aionotify @@ -25,11 +29,13 @@ if AIODEBUG: TESTDIR = os.environ.get('AIOTESTDIR') or os.path.join(os.path.dirname(__file__), 'testevents') -class AIONotifyTestCase(asynctest.TestCase): +class AIONotifyTestCase(testBase): forbid_get_event_loop = True timeout = 3 def setUp(self): + if not getattr (self, 'loop', None): + self.loop = asyncio.get_event_loop() if AIODEBUG: self.loop.set_debug(True) self.watcher = aionotify.Watcher() id=ee3d20b9de26945d7165189d2a04900fbb785318'>treecommitdiff
path: root/gnu/installer/newt/menu.scm
13:43:20 +0200'>2020-07-31
AgeCommit message (Expand)Author
2019-05-05installer: Fix typo....Miguel
2019-01-17installer: menu: Fix typo....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe
file-system: Add mount-may-fail? option....Mathieu Othacehe
2020-07-31file-systems: Add %debug-file-system....Mathieu Othacehe
2020-07-25file-systems: Convey hint via '&fix-hint'....Ludovic Courtès
2020-05-20bootloader: grub: Allow booting from a Btrfs subvolume....Maxim Cournoyer
2020-05-20file-systems: Add helpers for parsing the options string into an alist....Maxim Cournoyer
2020-04-27file-systems: mount the PID cgroup filesystem....Jakub Kądziołka
2020-03-02file-systems: Add a 'file-system-device->string' procedure....Maxim Cournoyer
2019-11-04file-systems: Mount /var/run/nscd read-write in containers....Ludovic Courtès
2019-09-12file-systems: Add /var/run/nscd to '%network-file-mappings'....Ludovic Courtès
2019-07-19file-systems: Use 'no-atime' for %IMMUTABLE-STORE....Ludovic Courtès