Fix CVE-2018-14647: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14647 https://bugs.python.org/issue34623 Taken from upstream: https://github.com/python/cpython/commit/f7666e828cc3d5873136473ea36ba2013d624fa1 diff --git Include/pyexpat.h Include/pyexpat.h index 44259bf6d7..07020b5dc9 100644 --- Include/pyexpat.h +++ Include/pyexpat.h @@ -3,7 +3,7 @@ /* note: you must import expat.h before importing this module! */ -#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.0" +#define PyExpat_CAPI_MAGIC "pyexpat.expat_CAPI 1.1" #define PyExpat_CAPSULE_NAME "pyexpat.expat_CAPI" struct PyExpat_CAPI @@ -48,6 +48,8 @@ struct PyExpat_CAPI enum XML_Status (*SetEncoding)(XML_Parser parser, const XML_Char *encoding); int (*DefaultUnknownEncodingHandler)( void *encodingHandlerData, const XML_Char *name, XML_Encoding *info); + /* might be none for expat < 2.1.0 */ + int (*SetHashSalt)(XML_Parser parser, unsigned long hash_salt); /* always add new stuff to the end! */ }; diff --git Modules/_elementtree.c Modules/_elementtree.c index 707ab2912b..53f05f937f 100644 --- Modules/_elementtree.c +++ Modules/_elementtree.c @@ -3261,6 +3261,11 @@ _elementtree_XMLParser___init___impl(XMLParserObject *self, PyObject *html, PyErr_NoMemory(); return -1; } + /* expat < 2.1.0 has no XML_SetHashSalt() */ + if (EXPAT(SetHashSalt) != NULL) { + EXPAT(SetHashSalt)(self->parser, + (unsigned long)_Py_HashSecret.expat.hashsalt); + } if (target) { Py_INCREF(target); diff --git Modules/pyexpat.c Modules/pyexpat.c index 47c3e86c20..aa21d93c11 100644 --- Modules/pyexpat.c +++ Modules/pyexpat.c @@ -1887,6 +1887,11 @@ MODULE_INITFUNC(void) capi.SetStartDoctypeDeclHandler = XML_SetStartDoctypeDeclHandler; capi.SetEncoding = XML_SetEncoding; capi.DefaultUnknownEncodingHandler = PyUnknownEncodingHandler; +#if XML_COMBINED_VERSION >= 20100 + capi.SetHashSalt = XML_SetHashSalt; +#else + capi.SetHashSalt = NULL; +#endif /* export using capsule */ capi_object = PyCapsule_New(&capi, PyExpat_CAPSULE_NAME, NULL); ?id=dc67e9e5b2485e7a2f50b3979bdff968028eec42&showmsg=1'>HACKING
AgeCommit message (Collapse)Author
2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual.Ludovic Courtès
* HACKING (Commit Access): Remove. (Contributing): Update URL of the manual. * doc/contributing.texi (Commit Access): New section. (Submitting Patches): Add cross reference.
2020-01-09doc: Add "Tracking Bugs and Patches" section.Ludovic Courtès
* doc/contributing.texi (Tracking Bugs and Patches): New section. (Submitting Patches): Refer to it. * doc/guix.texi: Update copyright line. * HACKING (Using emacs-debbugs): Remove.
2019-07-13doc: Update keyserver URL.Leo Famulari
* HACKING (Commit Access): Change keyserver URL to 'keys.openpgp.org'.
2019-02-11HACKING: Update key server.Ludovic Courtès
* HACKING (Commit Access): Recommend pool.sks-keyservers.net.
2018-07-22doc: Fix typo (missing period)Pierre Neidhardt
* HACKING (Commit Access): Fix typo.
2017-08-19doc: Mention how to use emacs-debbugs.Arun Isaac
* HACKING (Using emacs-debbugs): Add section on using emacs-debbugs.
2017-03-27maint: Give command to install the pre-push hook.Ludovic Courtès
* HACKING: Add 'cp' line to install the pre-push hook.
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'.Clément Lassieur
* HACKING: Mention the Signed-off-by line.
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'.Ludovic Courtès
Fixes <http://bugs.gnu.org/25899>. * HACKING: Mention guix-patches@gnu.org.
2017-01-30maint: Fix invalid calls to 'info'.Mathieu Lirzin
* HACKING <Contributing>: Remove name of the manual from the item argument. * README <Installation>: Likewise.
2017-01-04doc: Add a Git hook that verifies signatures before pushing.Leo Famulari
* HACKING (Commit Access): Describe the pre-push Git hook. * etc/git/pre-push: New file.